summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/rb_libtorrent/rb_libtorrent-0.14.6.ebuild')
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.14.6.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.14.6.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.14.6.ebuild
index 4964458f5d65..96af94e97c86 100644
--- a/net-libs/rb_libtorrent/rb_libtorrent-0.14.6.ebuild
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.14.6.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.14.6.ebuild,v 1.2 2009/10/27 10:39:28 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.14.6.ebuild,v 1.3 2009/11/10 18:21:58 yngwin Exp $
EAPI="2"
-inherit eutils flag-o-matic
+inherit autotools eutils flag-o-matic
MY_P=${P/rb_/}
MY_P=${MY_P/torrent/torrent-rasterbar}
@@ -26,6 +26,11 @@ DEPEND="!net-libs/libtorrent
sys-libs/zlib"
RDEPEND="${DEPEND}"
+src_prepare() {
+ epatch "${FILESDIR}"/0.14.6-configure-ldflags-fix.patch #290756
+ eautoreconf
+}
+
src_configure() {
append-ldflags -pthread