summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/qxmpp/qxmpp-0.7.4.ebuild')
-rw-r--r--net-libs/qxmpp/qxmpp-0.7.4.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/net-libs/qxmpp/qxmpp-0.7.4.ebuild b/net-libs/qxmpp/qxmpp-0.7.4.ebuild
index 13a01c974dfc..946e78fae776 100644
--- a/net-libs/qxmpp/qxmpp-0.7.4.ebuild
+++ b/net-libs/qxmpp/qxmpp-0.7.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/qxmpp/qxmpp-0.7.4.ebuild,v 1.2 2012/10/04 15:19:59 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/qxmpp/qxmpp-0.7.4.ebuild,v 1.3 2012/10/14 18:04:31 pinkbyte Exp $
EAPI=4
@@ -13,11 +13,12 @@ SRC_URI="http://qxmpp.googlecode.com/files/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="debug doc"
+IUSE="debug doc test"
DEPEND="x11-libs/qt-core:4
x11-libs/qt-gui:4
- media-libs/speex"
+ media-libs/speex
+ test? ( x11-libs/qt-test:4 )"
RDEPEND="${DEPEND}"
src_prepare(){
@@ -27,6 +28,10 @@ src_prepare(){
-e '/INSTALLS/d' \
qxmpp.pro || die "sed for removing docs failed"
fi
+ if ! use test; then
+ sed -i -e '/SUBDIRS/s/tests//' \
+ qxmpp.pro || die "sed for removing tests failed"
+ fi
qt4-r2_src_prepare
}