summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/glib-networking/glib-networking-2.30.1.ebuild')
-rw-r--r--net-libs/glib-networking/glib-networking-2.30.1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/net-libs/glib-networking/glib-networking-2.30.1.ebuild b/net-libs/glib-networking/glib-networking-2.30.1.ebuild
new file mode 100644
index 000000000000..c4f8d4b74253
--- /dev/null
+++ b/net-libs/glib-networking/glib-networking-2.30.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/glib-networking/glib-networking-2.30.1.ebuild,v 1.1 2011/10/18 18:50:22 pacho Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Network-related giomodules for glib"
+HOMEPAGE="http://git.gnome.org/browse/glib-networking/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86
+~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos
+~sparc-solaris ~x86-solaris"
+IUSE="+gnome +libproxy +ssl"
+
+RDEPEND=">=dev-libs/glib-2.29.16:2
+ gnome? ( gnome-base/gsettings-desktop-schemas )
+ libproxy? ( >=net-libs/libproxy-0.4.6-r3 )
+ ssl? (
+ app-misc/ca-certificates
+ >=net-libs/gnutls-2.1.7 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35.0
+ >=dev-util/pkgconfig-0.9
+ sys-devel/gettext"
+
+pkg_setup() {
+ # AUTHORS, ChangeLog are empty
+ DOCS="NEWS README"
+ G2CONF="${G2CONF}
+ --disable-static
+ --with-ca-certificates=${EPREFIX}/etc/ssl/certs/ca-certificates.crt
+ $(use_with gnome gnome-proxy)
+ $(use_with libproxy)
+ $(use_with ssl gnutls)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Drop DEPRECATED flags
+ sed -i -e 's:-D[A-Z_]*DISABLE_DEPRECATED:$(NULL):g' \
+ proxy/libproxy/Makefile.am proxy/libproxy/Makefile.in \
+ proxy/gnome/Makefile.am proxy/gnome/Makefile.in \
+ tls/gnutls/Makefile.am tls/gnutls/Makefile.in || die
+}