summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nmap/nmap-3.81.ebuild')
-rw-r--r--net-analyzer/nmap/nmap-3.81.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-analyzer/nmap/nmap-3.81.ebuild b/net-analyzer/nmap/nmap-3.81.ebuild
new file mode 100644
index 000000000000..a2c27a848e87
--- /dev/null
+++ b/net-analyzer/nmap/nmap-3.81.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-3.81.ebuild,v 1.1 2005/02/08 17:08:02 spock Exp $
+
+inherit eutils
+
+DESCRIPTION="A utility for network exploration or security auditing"
+HOMEPAGE="http://www.insecure.org/nmap/"
+SRC_URI="http://www.insecure.org/nmap/dist/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~arm ~hppa ~amd64 ~ppc64 ~s390 ~ia64 ~ppc-macos"
+IUSE="gtk gnome ipv6"
+
+DEPEND="virtual/libc
+ dev-libs/libpcre
+ gtk? ( =x11-libs/gtk+-1.2* )"
+
+src_compile() {
+ econf `use_with gtk nmapfe` \
+ `use_enable ipv6` || die
+ emake -j1 || die
+}
+
+src_install() {
+ einstall -j1 nmapdatadir=${D}/usr/share/nmap install || die
+ use gnome || rm -rf ${D}/usr/share/gnome/
+
+ dodoc CHANGELOG HACKING INSTALL docs/README docs/*.txt
+ dohtml docs/*.html
+}