summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/cdtool/cdtool-2.1.5-r1.ebuild')
-rw-r--r--media-sound/cdtool/cdtool-2.1.5-r1.ebuild19
1 files changed, 14 insertions, 5 deletions
diff --git a/media-sound/cdtool/cdtool-2.1.5-r1.ebuild b/media-sound/cdtool/cdtool-2.1.5-r1.ebuild
index 8d9c2720f4d4..55b7a51f73e9 100644
--- a/media-sound/cdtool/cdtool-2.1.5-r1.ebuild
+++ b/media-sound/cdtool/cdtool-2.1.5-r1.ebuild
@@ -1,18 +1,27 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/cdtool/cdtool-2.1.5-r1.ebuild,v 1.1 2005/04/20 19:01:26 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cdtool/cdtool-2.1.5-r1.ebuild,v 1.2 2006/03/07 13:58:19 flameeyes Exp $
+
+inherit eutils toolchain-funcs
DESCRIPTION="A package of command-line utilities to play and catalog cdroms."
-HOMEPAGE=""
+HOMEPAGE="none"
SRC_URI="http://www.ibiblio.org/pub/linux/apps/sound/cdrom/cli/cdtool-${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 sparc amd64 ppc"
-IUSE=""
+IUSE="debug"
DEPEND="!media-sound/cdplay"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${FILESDIR}/${P}-ldflags.patch"
+}
+
src_compile() {
- emake || die "make failed"
+ use debug && append-flags -DDEBUG
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" || die "make failed"
}
src_install() {