summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/mythweather/mythweather-0.10.ebuild')
-rw-r--r--media-plugins/mythweather/mythweather-0.10.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-plugins/mythweather/mythweather-0.10.ebuild b/media-plugins/mythweather/mythweather-0.10.ebuild
new file mode 100644
index 000000000000..4d0b18e261f6
--- /dev/null
+++ b/media-plugins/mythweather/mythweather-0.10.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythweather/mythweather-0.10.ebuild,v 1.1 2003/07/08 23:56:30 johnm Exp $
+
+inherit flag-o-matic
+
+IUSE=""
+DESCRIPTION="Weather forcast module for MythTV."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=media-tv/mythtv-${PV}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+
+ unpack ${A}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:/usr/local:/usr:" -i "${i}" || die "sed failed"
+ done
+
+}
+
+src_compile() {
+
+ cpu="`get-flag march`"
+ if [ ! -z "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "${S}/settings.pro" || die "sed failed"
+ fi
+
+ qmake -o "${S}/Makefile" "${S}/${PN}.pro"
+
+ emake || die "compile problem"
+
+}
+
+src_install() {
+
+ make INSTALL_ROOT="${D}" install || die "make install failed"
+
+ dodoc AUTHORS COPYING README
+
+}