summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libkface/libkface-3.5.0.ebuild')
-rw-r--r--media-libs/libkface/libkface-3.5.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-libs/libkface/libkface-3.5.0.ebuild b/media-libs/libkface/libkface-3.5.0.ebuild
new file mode 100644
index 000000000000..d774c59411a7
--- /dev/null
+++ b/media-libs/libkface/libkface-3.5.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libkface/libkface-3.5.0.ebuild,v 1.1 2013/10/12 16:49:32 dilfridge Exp $
+
+EAPI=5
+
+DIGIKAMPN=digikam
+
+KDE_LINGUAS=""
+KDE_MINIMAL="4.10"
+
+CMAKE_MIN_VERSION=2.8
+
+inherit kde4-base
+
+MY_PV=${PV/_/-}
+MY_P="digikam-${MY_PV}"
+SRC_URI="mirror://kde/stable/digikam/${MY_P}.tar.bz2"
+
+DESCRIPTION="Qt/C++ wrapper around LibFace to perform face recognition and detection"
+HOMEPAGE="http://www.digikam.org/"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+SLOT=4
+
+DEPEND=">=media-libs/opencv-2.4.5"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${MY_P}/extra/${PN}
+
+src_configure() {
+ mycmakeargs=(
+ -DFORCED_UNBUNDLE=ON
+ )
+ kde4-base_src_configure
+}