summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/superkaramba/superkaramba-4.3.4.ebuild')
-rw-r--r--kde-base/superkaramba/superkaramba-4.3.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/kde-base/superkaramba/superkaramba-4.3.4.ebuild b/kde-base/superkaramba/superkaramba-4.3.4.ebuild
new file mode 100644
index 000000000000..8ed6ae6231ea
--- /dev/null
+++ b/kde-base/superkaramba/superkaramba-4.3.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/superkaramba-4.3.4.ebuild,v 1.1 2009/12/01 11:34:32 wired Exp $
+
+EAPI="2"
+
+KMNAME="kdeutils"
+inherit kde4-meta
+
+DESCRIPTION="A tool to create interactive applets for the KDE desktop."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug +handbook python"
+
+DEPEND="
+ kde-base/qimageblitz
+ python? ( $(add_kdebase_dep pykde4) )
+"
+RDEPEND="${DEPEND}
+ python? ( $(add_kdebase_dep krosspython) )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-as-needed.patch" )
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with python PythonLibs)"
+
+ kde4-meta_src_configure
+}