summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/libkcddb/libkcddb-4.9.1.ebuild')
-rw-r--r--kde-base/libkcddb/libkcddb-4.9.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/kde-base/libkcddb/libkcddb-4.9.1.ebuild b/kde-base/libkcddb/libkcddb-4.9.1.ebuild
new file mode 100644
index 000000000000..acfda9077aee
--- /dev/null
+++ b/kde-base/libkcddb/libkcddb-4.9.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/libkcddb/libkcddb-4.9.1.ebuild,v 1.1 2012/09/04 18:45:46 johu Exp $
+
+EAPI=4
+
+inherit kde4-base
+
+DESCRIPTION="KDE library for CDDB"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug musicbrainz"
+
+# tests require network access and compare static data with online data
+# bug 280996
+RESTRICT=test
+
+DEPEND="
+ musicbrainz? ( media-libs/musicbrainz:5 )
+"
+RDEPEND="${DEPEND}"
+add_blocker kscd "<4.8.50"
+add_blocker kdemultimedia-kioslaves
+
+KMSAVELIBS="true"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with musicbrainz MusicBrainz5)
+ )
+
+ kde4-base_src_configure
+}