summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/ktouch/ktouch-3.5.8.ebuild')
-rw-r--r--kde-base/ktouch/ktouch-3.5.8.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/kde-base/ktouch/ktouch-3.5.8.ebuild b/kde-base/ktouch/ktouch-3.5.8.ebuild
new file mode 100644
index 000000000000..1975da495f6b
--- /dev/null
+++ b/kde-base/ktouch/ktouch-3.5.8.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ktouch/ktouch-3.5.8.ebuild,v 1.1 2007/10/19 23:39:49 philantrop Exp $
+KMNAME=kdeedu
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta
+
+DESCRIPTION="KDE: A program that helps you to learn and practice touch typing"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+DEPEND="$(deprange 3.5.7 $MAXKDEVER kde-base/libkdeedu)"
+
+RDEPEND="${DEPEND}"
+
+KMEXTRACTONLY="libkdeedu/kdeeduplot"
+KMCOPYLIB="libkdeeduplot libkdeedu/kdeeduplot"
+
+src_unpack() {
+ kde-meta_src_unpack
+
+ sed -i -e 's:Miscellaneous:X-Miscellaneous:' \
+ "${S}/${PN}/${PN}.desktop" || sed "Sed to fix .desktop files failed."
+}