summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kpilot')
-rw-r--r--kde-base/kpilot/ChangeLog7
-rw-r--r--kde-base/kpilot/files/digest-kpilot-3.5.83
-rw-r--r--kde-base/kpilot/kpilot-3.5.8.ebuild42
3 files changed, 51 insertions, 1 deletions
diff --git a/kde-base/kpilot/ChangeLog b/kde-base/kpilot/ChangeLog
index c65e59d131c3..13c154a4342c 100644
--- a/kde-base/kpilot/ChangeLog
+++ b/kde-base/kpilot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kpilot
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kpilot/ChangeLog,v 1.62 2007/09/25 05:17:13 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kpilot/ChangeLog,v 1.63 2007/10/19 23:24:10 philantrop Exp $
+
+*kpilot-3.5.8 (19 Oct 2007)
+
+ 19 Oct 2007; Wulf C. Krueger <philantrop@gentoo.org> +kpilot-3.5.8.ebuild:
+ Bump to KDE 3.5.8.
25 Sep 2007; Wulf C. Krueger <philantrop@gentoo.org> kpilot-3.5.7.ebuild:
Raised version dependency on libmal.
diff --git a/kde-base/kpilot/files/digest-kpilot-3.5.8 b/kde-base/kpilot/files/digest-kpilot-3.5.8
new file mode 100644
index 000000000000..829a0a174fc3
--- /dev/null
+++ b/kde-base/kpilot/files/digest-kpilot-3.5.8
@@ -0,0 +1,3 @@
+MD5 a1ffff553f1d6739c7791891028b176b kdepim-3.5.8.tar.bz2 14107449
+RMD160 bb34c7e88227a1ebdd8ff38ee41445f85969175e kdepim-3.5.8.tar.bz2 14107449
+SHA256 433f8541af0a05e0a7e15df5ecca8463a29b6574871b941a8312b04b2233fef1 kdepim-3.5.8.tar.bz2 14107449
diff --git a/kde-base/kpilot/kpilot-3.5.8.ebuild b/kde-base/kpilot/kpilot-3.5.8.ebuild
new file mode 100644
index 000000000000..b8d0a1efb79d
--- /dev/null
+++ b/kde-base/kpilot/kpilot-3.5.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kpilot/kpilot-3.5.8.ebuild,v 1.1 2007/10/19 23:24:10 philantrop Exp $
+
+KMNAME=kdepim
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="KPilot - HotSync software for KDE."
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+DEPEND=">=app-pda/pilot-link-0.12.0
+ >=dev-libs/libmal-0.44
+$(deprange $PV $MAXKDEVER kde-base/libkcal)
+$(deprange $PV $MAXKDEVER kde-base/libkdepim)
+$(deprange $PV $MAXKDEVER kde-base/kontact)"
+
+RDEPEND="${DEPEND}"
+
+# The tests are broken.
+RESTRICT="test"
+
+KMCOPYLIB="
+ libkcal libkcal
+ libkdepim libkdepim
+ libkpinterfaces kontact/interfaces"
+# libkcal is installed because a lot of headers are needed, but it don't have to be compiled
+KMEXTRACTONLY="
+ libkcal/
+ libkdepim libkdepim/
+ kontact/interfaces/"
+KMEXTRA="
+ kfile-plugins/palm-databases
+ kontact/plugins/kpilot/" # We add here the kontact's plugin instead of compiling it with kontact because it needs a lot of this programs deps.
+
+src_compile() {
+ # needed to detect pi-notepad.h, used by the kpilot notepad conduit.
+ myconf="${myconf} --with-extra-includes=/usr/include/libpisock"
+
+ kde-meta_src_compile
+}