summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kghostview/kghostview-3.5.8.ebuild')
-rw-r--r--kde-base/kghostview/kghostview-3.5.8.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/kde-base/kghostview/kghostview-3.5.8.ebuild b/kde-base/kghostview/kghostview-3.5.8.ebuild
new file mode 100644
index 000000000000..906816ef3e37
--- /dev/null
+++ b/kde-base/kghostview/kghostview-3.5.8.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kghostview/kghostview-3.5.8.ebuild,v 1.1 2007/10/19 22:55:45 philantrop Exp $
+
+KMNAME=kdegraphics
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="KDE: Viewer for PostScript (.ps, .eps) and Portable Document Format (.pdf) files"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+# /Should/ also rdepend on kdeprint. Since kdeprint rdepends on kghostview for previews, we'd had a conflict, so we can't.
+RDEPEND="virtual/ghostscript"
+KMEXTRA="kfile-plugins/ps"
+
+pkg_setup() {
+ kde_pkg_setup
+ for ghostscript in app-text/ghostscript-{gnu,esp,afpl}; do
+ if has_version ${ghostscript} && ! built_with_use ${ghostscript} X; then
+ eerror "This package requires ${ghostscript} compiled with X11 support."
+ eerror "Please reemerge ${ghostscript} with USE=\"X\"."
+ die "Please reemerge ${ghostscript} with USE=\"X\"."
+ fi
+ done
+}