summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/dolphin/dolphin-4.1.4.ebuild')
-rw-r--r--kde-base/dolphin/dolphin-4.1.4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/kde-base/dolphin/dolphin-4.1.4.ebuild b/kde-base/dolphin/dolphin-4.1.4.ebuild
new file mode 100644
index 000000000000..b146b2652b3c
--- /dev/null
+++ b/kde-base/dolphin/dolphin-4.1.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/dolphin-4.1.4.ebuild,v 1.1 2009/01/13 21:07:06 alexxy Exp $
+
+EAPI="2"
+
+KMNAME=kdebase
+KMMODULE=apps/${PN}
+inherit kde4-meta
+
+DESCRIPTION="A KDE filemanager focusing on usability"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="debug htmlhandbook +semantic-desktop"
+
+DEPEND=">=kde-base/libkonq-${PV}:${SLOT}
+ kde-base/kdelibs:${SLOT}[semantic-desktop=]
+ kde-base/kdebase-data:${SLOT}
+ semantic-desktop? ( >=kde-base/nepomuk-${PV}:${SLOT}
+ >=dev-libs/soprano-2.0.7 )"
+RDEPEND="${DEPEND}"
+
+KMEXTRA="apps/doc/${PN}"
+KMLOADLIBS="libkonq"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)"
+ kde4-meta_src_configure
+}