summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnustep-base/gnustep-make/files/gnustep.csh')
-rw-r--r--gnustep-base/gnustep-make/files/gnustep.csh21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnustep-base/gnustep-make/files/gnustep.csh b/gnustep-base/gnustep-make/files/gnustep.csh
new file mode 100644
index 000000000000..fbb176a23734
--- /dev/null
+++ b/gnustep-base/gnustep-make/files/gnustep.csh
@@ -0,0 +1,21 @@
+#!/bin/csh
+
+if ( -e /etc/GNUstep/GNUstep.conf ) then
+ eval `sed -e '/^[^#=][^#=]*=.*$/\\!d' -e 's/^\([^#=][^#=]*\)=\(.*\)$/setenv \1 \2;/' /etc/GNUstep/GNUstep.conf`
+else
+ GNUSTEP_SYSTEM_ROOT="/usr/GNUstep/System"
+endif
+
+source $GNUSTEP_SYSTEM_ROOT/Library/Makefiles/GNUstep.csh
+
+if ( -z "$GNUSTEP_FLATTENED" ) then
+ set TDIR=${GNUSTEP_SYSTEM_ROOT}/Tools/${GNUSTEP_HOST_CPU}/${GNUSTEP_HOST_OS}/${LIBRARY_COMBO}
+else
+ set TDIR=${GNUSTEP_SYSTEM_ROOT}/Tools
+endif
+
+if ( -x $TDIR/make_services ) then
+ $TDIR/make_services
+endif
+
+unset TDIR \ No newline at end of file