summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnustep-base/gnustep-back-cairo/gnustep-back-cairo-0.13.2.ebuild')
-rw-r--r--gnustep-base/gnustep-back-cairo/gnustep-back-cairo-0.13.2.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnustep-base/gnustep-back-cairo/gnustep-back-cairo-0.13.2.ebuild b/gnustep-base/gnustep-back-cairo/gnustep-back-cairo-0.13.2.ebuild
index 403975fc0db6..0fb958681d08 100644
--- a/gnustep-base/gnustep-back-cairo/gnustep-back-cairo-0.13.2.ebuild
+++ b/gnustep-base/gnustep-back-cairo/gnustep-back-cairo-0.13.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-back-cairo/gnustep-back-cairo-0.13.2.ebuild,v 1.2 2008/05/17 20:12:35 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-back-cairo/gnustep-back-cairo-0.13.2.ebuild,v 1.3 2008/06/10 14:31:18 voyageur Exp $
inherit gnustep-base
@@ -36,6 +36,15 @@ RDEPEND="${GNUSTEP_CORE_DEPEND}
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+pkg_setup() {
+ gnustep-base_pkg_setup
+
+ if ! built_with_use x11-libs/cairo X; then
+ eerror "x11-libs/cairo must be compiled with the X USE flag enabled"
+ die "x11-libs/cairo rebuild needed"
+ fi
+}
+
src_compile() {
egnustep_env