summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/at-spi/at-spi-0.12.1-r1.ebuild')
-rw-r--r--gnome-extra/at-spi/at-spi-0.12.1-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnome-extra/at-spi/at-spi-0.12.1-r1.ebuild b/gnome-extra/at-spi/at-spi-0.12.1-r1.ebuild
new file mode 100644
index 000000000000..ad093e7b5486
--- /dev/null
+++ b/gnome-extra/at-spi/at-spi-0.12.1-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/at-spi-0.12.1-r1.ebuild,v 1.1 2002/06/01 13:31:17 spider Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="This is the Gnome Accessibility Toolkit"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/pre-gnome2/sources/at-spi/${P}.tar.bz2"
+HOMEPAGE="http://www.gnome.org/"
+SLOT="0"
+LICENSE="LGPL-2.1"
+
+RDEPEND=">=gnome-base/gail-0.9
+ >=gnome-base/libbonobo-1.112.0
+ >=dev-libs/popt-1.6.3"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ doc? ( dev-util/gtk-doc )"
+
+src_compile() {
+ local myconf
+ libtoolize --copy --force
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --enable-debug=yes || die
+
+ emake || die "compile failed"
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ install || die
+
+ # hack for borken makefile
+ insinto /usr/include/at-spi-1.0/libspi
+ doins libspi/stateset.h
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+}
+
+
+
+
+