summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/showeq/showeq-5.3.0.0.ebuild')
-rw-r--r--games-util/showeq/showeq-5.3.0.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/games-util/showeq/showeq-5.3.0.0.ebuild b/games-util/showeq/showeq-5.3.0.0.ebuild
new file mode 100644
index 000000000000..a8100cb8e019
--- /dev/null
+++ b/games-util/showeq/showeq-5.3.0.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/showeq/showeq-5.3.0.0.ebuild,v 1.1 2006/03/17 21:22:45 tupone Exp $
+
+inherit kde games
+
+DESCRIPTION="An Everquest monitoring program"
+HOMEPAGE="http://www.showeq.net/"
+SRC_URI="mirror://sourceforge/seq/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="virtual/libpcap
+ $(qt_min_version 3.2)
+ >=sys-libs/gdbm-1.8.0"
+
+DEPEND="${RDEPEND}
+ || ( x11-libs/libXt virtual/x11 )"
+
+src_compile() {
+ kde_src_compile nothing
+ egamesconf || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ doman showeq.1
+ dodoc AUTHORS BUGS ChangeLog FAQ NEWS README ROADMAP TODO doc/*.{doc,txt}
+ dohtml doc/map.html
+ prepgamesdirs
+}