summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-sports/foobillard/foobillard-2.9.ebuild')
-rw-r--r--games-sports/foobillard/foobillard-2.9.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-sports/foobillard/foobillard-2.9.ebuild b/games-sports/foobillard/foobillard-2.9.ebuild
new file mode 100644
index 000000000000..0ed9782c7869
--- /dev/null
+++ b/games-sports/foobillard/foobillard-2.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/foobillard/foobillard-2.9.ebuild,v 1.1 2003/11/10 04:25:54 vapier Exp $
+
+inherit games
+
+DESCRIPTION="8ball, 9ball, snooker and carambol game"
+HOMEPAGE="http://foobillard.sunsite.dk/"
+SRC_URI="http://foobillard.sunsite.dk/dnl/${P}.tar.gz"
+
+KEYWORDS="x86 ppc"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="sdl"
+
+DEPEND="virtual/x11
+ virtual/opengl
+ >=media-libs/freetype-2.0.9
+ >=media-libs/libpng-1.2.1
+ || (
+ sdl? ( media-libs/libsdl )
+ ( virtual/glu virtual/glut )
+ )"
+
+src_compile() {
+ local myconf=""
+ [ "`ls /usr/include/GL/gl.h -al | awk '{print $NF}' | cut -d/ -f5`" == "nvidia" ] \
+ && myconf="--enable-nvidia" \
+ || myconf="--disable-nvidia"
+ myconf="${myconf} `use_enable sdl SDL`"
+ use sdl \
+ && myconf="${myconf} --disable-glut" \
+ || myconf="${myconf} --enable-glut"
+
+ egamesconf \
+ --enable-sound \
+ ${myconf} \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README README.FONTS AUTHORS NEWS ChangeLog
+ prepgamesdirs
+}