summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/gl117/ChangeLog8
-rw-r--r--games-simulation/gl117/Manifest7
-rw-r--r--games-simulation/gl117/files/1.3-gcc-3.4-gentoo.patch53
-rw-r--r--games-simulation/gl117/files/digest-gl117-1.3-r11
-rw-r--r--games-simulation/gl117/gl117-1.3-r1.ebuild35
5 files changed, 101 insertions, 3 deletions
diff --git a/games-simulation/gl117/ChangeLog b/games-simulation/gl117/ChangeLog
index 248c2a7fc3e8..3a3e18588eaf 100644
--- a/games-simulation/gl117/ChangeLog
+++ b/games-simulation/gl117/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-simulation/gl117
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/gl117/ChangeLog,v 1.8 2004/06/13 02:32:05 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/gl117/ChangeLog,v 1.9 2004/06/13 18:44:22 mkennedy Exp $
+
+*gl117-1.3-r1 (13 Jun 2004)
+
+ 13 Jun 2004; <mkennedy@gentoo.org> +files/1.3-gcc-3.4-gentoo.patch,
+ +gl117-1.3-r1.ebuild:
+ Patch to get a successful build with GCC 3.4.0
*gl117-1.3 (12 Jun 2004)
diff --git a/games-simulation/gl117/Manifest b/games-simulation/gl117/Manifest
index 436e466fafed..981d2b5eb967 100644
--- a/games-simulation/gl117/Manifest
+++ b/games-simulation/gl117/Manifest
@@ -1,6 +1,9 @@
-MD5 e577c241ef782ca6a576b29a3a1e17ed ChangeLog 1304
+MD5 9c39378ab87e04c92b53be4325473a1b gl117-1.2.ebuild 776
+MD5 6da9c3238e27fd6510a956cbe7ca9070 gl117-1.3-r1.ebuild 823
MD5 6a7abfd237e3d0b6d722a744b66f11e9 gl117-1.3.ebuild 743
+MD5 cf5ea4c156d021d3a37acb6ae9536a92 ChangeLog 1476
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 a4aa3dc96f3709745548ec79d08d1124 gl117-1.2.ebuild 775
+MD5 933609db8a5eee32fd345edfcad90939 files/1.3-gcc-3.4-gentoo.patch 1560
MD5 b71cc371a34ed8325ca96ab27964f748 files/digest-gl117-1.3 68
+MD5 b71cc371a34ed8325ca96ab27964f748 files/digest-gl117-1.3-r1 68
MD5 945f07eb6f434e41cfcb6dd284717073 files/digest-gl117-1.2 67
diff --git a/games-simulation/gl117/files/1.3-gcc-3.4-gentoo.patch b/games-simulation/gl117/files/1.3-gcc-3.4-gentoo.patch
new file mode 100644
index 000000000000..372faad78944
--- /dev/null
+++ b/games-simulation/gl117/files/1.3-gcc-3.4-gentoo.patch
@@ -0,0 +1,53 @@
+Only in gl-117-1.3-src: Makefile
+Only in gl-117-1.3-src: config.h
+Only in gl-117-1.3-src: config.log
+Only in gl-117-1.3-src: config.status
+diff -ur gl-117-1.3-src.orig/src/3ds.cpp gl-117-1.3-src/src/3ds.cpp
+--- gl-117-1.3-src.orig/src/3ds.cpp 2004-06-12 00:44:13.000000000 -0500
++++ gl-117-1.3-src/src/3ds.cpp 2004-06-13 13:29:13.191525808 -0500
+@@ -759,7 +759,7 @@
+ v->vector.z /= sc;
+ }
+ }
+-};
++}
+
+ #endif
+
+diff -ur gl-117-1.3-src.orig/src/audio.cpp gl-117-1.3-src/src/audio.cpp
+--- gl-117-1.3-src.orig/src/audio.cpp 2004-06-12 00:44:13.000000000 -0500
++++ gl-117-1.3-src/src/audio.cpp 2004-06-13 13:28:17.695962416 -0500
+@@ -322,7 +322,7 @@
+ wavemissile1->setVolume (110);
+ waveclick1->setVolume (80);
+ #endif
+-};
++}
+
+ SoundSystem::~SoundSystem ()
+ {
+diff -ur gl-117-1.3-src.orig/src/model.cpp gl-117-1.3-src/src/model.cpp
+--- gl-117-1.3-src.orig/src/model.cpp 2004-06-12 00:44:13.000000000 -0500
++++ gl-117-1.3-src/src/model.cpp 2004-06-13 13:27:52.980719704 -0500
+@@ -57,7 +57,7 @@
+ c [0] = cr; c [1] = cg; c [2] = cb; c [3] = ca;
+ }
+
+-CColor::~CColor () {};
++CColor::~CColor () {}
+
+ void CColor::setColor (CColor *col)
+ {
+diff -ur gl-117-1.3-src.orig/src/objload.cpp gl-117-1.3-src/src/objload.cpp
+--- gl-117-1.3-src.orig/src/objload.cpp 2004-06-12 00:44:13.000000000 -0500
++++ gl-117-1.3-src/src/objload.cpp 2004-06-13 13:28:21.967313072 -0500
+@@ -247,7 +247,7 @@
+ }
+
+ // model->scale = sc;
+-};
++}
+
+ bool CLoadOBJ::ImportOBJ (CModel *model, char *filename)
+ {
+Only in gl-117-1.3-src: stamp-h1
diff --git a/games-simulation/gl117/files/digest-gl117-1.3-r1 b/games-simulation/gl117/files/digest-gl117-1.3-r1
new file mode 100644
index 000000000000..99b4098b4603
--- /dev/null
+++ b/games-simulation/gl117/files/digest-gl117-1.3-r1
@@ -0,0 +1 @@
+MD5 38740f8d354416d3ae30f1b0e1c203c7 gl-117-1.3-src.tar.bz2 2354750
diff --git a/games-simulation/gl117/gl117-1.3-r1.ebuild b/games-simulation/gl117/gl117-1.3-r1.ebuild
new file mode 100644
index 000000000000..ad4a9c4b52e3
--- /dev/null
+++ b/games-simulation/gl117/gl117-1.3-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/gl117/gl117-1.3-r1.ebuild,v 1.1 2004/06/13 18:44:22 mkennedy Exp $
+
+inherit games
+
+MY_P="gl-117-${PV}-src"
+DESCRIPTION="An action flight simulator"
+HOMEPAGE="http://home.t-online.de/home/primetime./gl-117/"
+SRC_URI="mirror://sourceforge/gl-117/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc"
+IUSE=""
+
+DEPEND="virtual/x11
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ virtual/opengl
+ virtual/glu
+ virtual/glut"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-gcc-3.4-gentoo.patch
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog FAQ NEWS README
+ prepgamesdirs
+}