summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-engines/exult/exult-1.00.ebuild')
-rw-r--r--games-engines/exult/exult-1.00.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/games-engines/exult/exult-1.00.ebuild b/games-engines/exult/exult-1.00.ebuild
new file mode 100644
index 000000000000..326cc10a33e9
--- /dev/null
+++ b/games-engines/exult/exult-1.00.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/exult/exult-1.00.ebuild,v 1.1 2003/09/09 17:34:21 vapier Exp $
+
+inherit games
+
+DESCRIPTION="an Ultima 7 game engine that runs on modern operating systems"
+SRC_URI="mirror://sourceforge/exult/${P}.tar.gz"
+HOMEPAGE="http://exult.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc"
+
+RDEPEND=">=media-libs/libsdl-1.2*
+ >=media-sound/timidity++-2*"
+
+pkg_setup() {
+ ewarn "*********************************************************"
+ ewarn " I had massive problems with exult when using agressive"
+ ewarn " CFLAGS and CXXFLAGS. If exult segfaults try less"
+ ewarn " agressive optimizations and/or a different -march"
+ ewarn " e.g.: -march=i386 instead of -march=i686 on x86"
+ ewarn "*********************************************************"
+}
+
+src_compile() {
+ egamesconf
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc AUTHORS ChangeLog COPYING NEWS FAQ README README.1ST
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ einfo "To hear music in exult,"
+ einfo "you have to install a timidity-patch."
+ einfo "Try this:"
+ einfo " $ emerge timidity-eawpatches"
+ einfo "kernel drivers. Install alsa instead."
+ einfo
+ einfo "You *must* have the original Ultima7 The Black Gate and/or"
+ einfo "The Serpent Isle installed. "
+ einfo "See /usr/doc/${PF}/README.gz for infos!"
+}