summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/fbzx/fbzx-1.10.ebuild')
-rw-r--r--games-emulation/fbzx/fbzx-1.10.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/games-emulation/fbzx/fbzx-1.10.ebuild b/games-emulation/fbzx/fbzx-1.10.ebuild
index b0f6657139cc..fdfff16ae9a5 100644
--- a/games-emulation/fbzx/fbzx-1.10.ebuild
+++ b/games-emulation/fbzx/fbzx-1.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/fbzx/fbzx-1.10.ebuild,v 1.1 2007/12/08 09:52:16 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fbzx/fbzx-1.10.ebuild,v 1.2 2007/12/10 01:08:09 mr_bones_ Exp $
inherit eutils toolchain-funcs games
@@ -29,6 +29,11 @@ src_unpack() {
Makefile || die "sed failed"
}
+src_compile() {
+ rm -f fbzx_fs fbzx *.o # clean out accidentally packaged .o files
+ emake || die
+}
+
src_install() {
dogamesbin fbzx || die "dogamesbin failed"
insinto "${GAMES_DATADIR}/${PN}/roms"