summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/dosbox/dosbox-0.58.ebuild')
-rw-r--r--games-emulation/dosbox/dosbox-0.58.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/games-emulation/dosbox/dosbox-0.58.ebuild b/games-emulation/dosbox/dosbox-0.58.ebuild
new file mode 100644
index 000000000000..94395f793a75
--- /dev/null
+++ b/games-emulation/dosbox/dosbox-0.58.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/dosbox-0.58.ebuild,v 1.3 2004/02/11 02:55:42 vapier Exp $
+
+inherit games
+
+DESCRIPTION="DOS emulator"
+HOMEPAGE="http://dosbox.sourceforge.net/"
+SRC_URI="mirror://sourceforge/dosbox/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="sys-libs/ncurses
+ >=media-libs/libsdl-1.2.0
+ sys-libs/zlib"
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc AUTHORS ChangeLog INSTALL NEWS README THANKS
+ prepgamesdirs
+}