summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/mustache/mustache-0.99.4-r2.ebuild')
-rw-r--r--dev-ruby/mustache/mustache-0.99.4-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/mustache/mustache-0.99.4-r2.ebuild b/dev-ruby/mustache/mustache-0.99.4-r2.ebuild
new file mode 100644
index 000000000000..1e6c9adeb553
--- /dev/null
+++ b/dev-ruby/mustache/mustache-0.99.4-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mustache/mustache-0.99.4-r2.ebuild,v 1.1 2013/10/15 19:48:25 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC="man:build"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Mustache is a framework-agnostic way to render logic-free views."
+HOMEPAGE="http://mustache.github.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+ruby_add_bdepend "doc? ( app-text/ronn )"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:. -e "Dir['test/*.rb'].each{|f| require f}"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/mustache.1 man/mustache.5
+}