summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jsonpickle/jsonpickle-0.2.0.ebuild')
-rw-r--r--dev-python/jsonpickle/jsonpickle-0.2.0.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-python/jsonpickle/jsonpickle-0.2.0.ebuild b/dev-python/jsonpickle/jsonpickle-0.2.0.ebuild
deleted file mode 100644
index 09315b1230c2..000000000000
--- a/dev-python/jsonpickle/jsonpickle-0.2.0.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/jsonpickle/jsonpickle-0.2.0.ebuild,v 1.2 2009/06/30 20:46:18 fauli Exp $
-
-EAPI="2"
-
-inherit distutils
-
-DESCRIPTION="Python library for serializing any arbitrary object graph into JSON."
-HOMEPAGE="http://code.google.com/p/jsonpickle/"
-SRC_URI="http://jsonpickle.googlecode.com/files/${P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="|| ( >=dev-lang/python-2.6
- ( dev-lang/python:2.5 dev-python/simplejson ) )"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- sed -i \
- -e '/install_requires/d' \
- setup.py || die "sed failed"
- sed -i \
- -e '/thirdparty/d' \
- jsonpickle/tests/__init__.py || die "sed failed"
-}
-
-src_test() {
- PYTHONPATH="./build/lib" "${python}" setup.py test || die "tests failed"
-}