summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/cl-contextl/cl-contextl-0.21.ebuild')
-rw-r--r--dev-lisp/cl-contextl/cl-contextl-0.21.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-lisp/cl-contextl/cl-contextl-0.21.ebuild b/dev-lisp/cl-contextl/cl-contextl-0.21.ebuild
new file mode 100644
index 000000000000..24601ae87f86
--- /dev/null
+++ b/dev-lisp/cl-contextl/cl-contextl-0.21.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-contextl/cl-contextl-0.21.ebuild,v 1.1 2006/02/03 18:22:43 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="CLOS extension for context-oriented Programming"
+HOMEPAGE="http://common-lisp.net/project/closer/"
+SRC_URI="ftp://common-lisp.net/pub/project/closer/${P/cl-/}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-lisp/cl-lw-compat
+ dev-lisp/cl-closer-mop"
+
+CLPACKAGE=contextl
+
+S=${WORKDIR}/contextl
+
+src_install() {
+ common-lisp-install *.{lisp,asd}
+ common-lisp-system-symlink
+ insinto $CLSOURCEROOT/$CLPACKAGE/test
+ doins test/*.lisp
+}