summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/ucl/ucl-1.03.ebuild')
-rw-r--r--dev-libs/ucl/ucl-1.03.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-libs/ucl/ucl-1.03.ebuild b/dev-libs/ucl/ucl-1.03.ebuild
new file mode 100644
index 000000000000..2656a03960f0
--- /dev/null
+++ b/dev-libs/ucl/ucl-1.03.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ucl/ucl-1.03.ebuild,v 1.1 2004/08/30 09:50:00 gmsoft Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="UCL: The UCL Compression Library"
+HOMEPAGE="http://www.oberhumer.com/opensource/ucl/"
+SRC_URI="http://www.oberhumer.com/opensource/ucl/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~ppc64 ~ia64"
+IUSE=""
+
+src_compile() {
+ # Doing this b/c UCL will be included in the kernel
+ # at some point, and will be fixed properly then
+ # besides, this is lu_zero's build
+ append-flags -fPIC
+
+ econf || die
+ emake CFLAGS_O= || die
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+}