summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/linux-fusion/files/linux-fusion-3.2-newer-kernel.patch')
-rw-r--r--dev-libs/linux-fusion/files/linux-fusion-3.2-newer-kernel.patch155
1 files changed, 155 insertions, 0 deletions
diff --git a/dev-libs/linux-fusion/files/linux-fusion-3.2-newer-kernel.patch b/dev-libs/linux-fusion/files/linux-fusion-3.2-newer-kernel.patch
new file mode 100644
index 000000000000..d3a64b26df1d
--- /dev/null
+++ b/dev-libs/linux-fusion/files/linux-fusion-3.2-newer-kernel.patch
@@ -0,0 +1,155 @@
+Fixes ripped from upstream cvs
+
+http://bugs.gentoo.org/163740
+
+--- linux-fusion-3.2/linux/drivers/char/fusion/call.c
++++ linux-fusion-3.2/linux/drivers/char/fusion/call.c
+@@ -12,7 +12,9 @@
+ * 2 of the License, or (at your option) any later version.
+ */
+
++#ifdef HAVE_LINUX_CONFIG_H
+ #include <linux/config.h>
++#endif
+ #include <linux/types.h>
+ #include <linux/kernel.h>
+ #include <linux/slab.h>
+--- linux-fusion-3.2/linux/drivers/char/fusion/entries.c
++++ linux-fusion-3.2/linux/drivers/char/fusion/entries.c
+@@ -12,7 +12,9 @@
+ * 2 of the License, or (at your option) any later version.
+ */
+
++#ifdef HAVE_LINUX_CONFIG_H
+ #include <linux/config.h>
++#endif
+ #include <linux/types.h>
+ #include <linux/kernel.h>
+ #include <linux/slab.h>
+--- linux-fusion-3.2/linux/drivers/char/fusion/fusiondev.c
++++ linux-fusion-3.2/linux/drivers/char/fusion/fusiondev.c
+@@ -14,7 +14,9 @@
+
+ #include <linux/version.h>
+ #include <linux/module.h>
++#ifdef HAVE_LINUX_CONFIG_H
+ #include <linux/config.h>
++#endif
+ #include <linux/types.h>
+ #include <linux/kernel.h>
+ #include <linux/fs.h>
+@@ -22,6 +24,11 @@
+ #if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 18)
+ #include <linux/devfs_fs_kernel.h>
+ #endif
++#if LINUX_VERSION_CODE > KERNEL_VERSION(2, 6, 19)
++#include <linux/page-flags.h>
++#include <linux/mm.h>
++#endif
++
+ #include <linux/proc_fs.h>
+ #include <linux/poll.h>
+ #include <linux/init.h>
+--- linux-fusion-3.2/linux/drivers/char/fusion/fusionee.c
++++ linux-fusion-3.2/linux/drivers/char/fusion/fusionee.c
+@@ -12,7 +12,9 @@
+ * 2 of the License, or (at your option) any later version.
+ */
+
++#ifdef HAVE_LINUX_CONFIG_H
+ #include <linux/config.h>
++#endif
+ #include <linux/types.h>
+ #include <linux/kernel.h>
+ #include <linux/slab.h>
+--- linux-fusion-3.2/linux/drivers/char/fusion/property.c
++++ linux-fusion-3.2/linux/drivers/char/fusion/property.c
+@@ -12,7 +12,9 @@
+ * 2 of the License, or (at your option) any later version.
+ */
+
++#ifdef HAVE_LINUX_CONFIG_H
+ #include <linux/config.h>
++#endif
+ #include <linux/types.h>
+ #include <linux/kernel.h>
+ #include <linux/slab.h>
+--- linux-fusion-3.2/linux/drivers/char/fusion/reactor.c
++++ linux-fusion-3.2/linux/drivers/char/fusion/reactor.c
+@@ -12,7 +12,9 @@
+ * 2 of the License, or (at your option) any later version.
+ */
+
++#ifdef HAVE_LINUX_CONFIG_H
+ #include <linux/config.h>
++#endif
+ #include <linux/types.h>
+ #include <linux/kernel.h>
+ #include <linux/slab.h>
+--- linux-fusion-3.2/linux/drivers/char/fusion/ref.c
++++ linux-fusion-3.2/linux/drivers/char/fusion/ref.c
+@@ -12,7 +12,9 @@
+ * 2 of the License, or (at your option) any later version.
+ */
+
++#ifdef HAVE_LINUX_CONFIG_H
+ #include <linux/config.h>
++#endif
+ #include <linux/types.h>
+ #include <linux/kernel.h>
+ #include <linux/slab.h>
+--- linux-fusion-3.2/linux/drivers/char/fusion/shmpool.c
++++ linux-fusion-3.2/linux/drivers/char/fusion/shmpool.c
+@@ -12,7 +12,9 @@
+ * 2 of the License, or (at your option) any later version.
+ */
+
++#ifdef HAVE_LINUX_CONFIG_H
+ #include <linux/config.h>
++#endif
+ #include <linux/types.h>
+ #include <linux/kernel.h>
+ #include <linux/slab.h>
+--- linux-fusion-3.2/linux/drivers/char/fusion/skirmish.c
++++ linux-fusion-3.2/linux/drivers/char/fusion/skirmish.c
+@@ -12,7 +12,9 @@
+ * 2 of the License, or (at your option) any later version.
+ */
+
++#ifdef HAVE_LINUX_CONFIG_H
+ #include <linux/config.h>
++#endif
+ #include <linux/types.h>
+ #include <linux/kernel.h>
+ #include <linux/slab.h>
+--- linux-fusion-3.2/linux/drivers/char/fusion/types.h
++++ linux-fusion-3.2/linux/drivers/char/fusion/types.h
+@@ -15,9 +15,15 @@
+ #ifndef __FUSION__TYPES_H__
+ #define __FUSION__TYPES_H__
+
++#include <linux/version.h>
++
++#if LINUX_VERSION_CODE <= KERNEL_VERSION(2, 6, 18)
+ typedef enum {
+ false = 0,
+ true = !false
+ } bool;
++#endif
++
++
+
+ #endif
+--- linux-fusion-3.2/Makefile
++++ linux-fusion-3.2/Makefile
+@@ -17,6 +17,10 @@
+ AUTOCONF_H = -include $(KERNEL_BUILD)/include/linux/autoconf.h
+ endif
+
++ifeq ($(shell test -e $(KERNEL_BUILD)/include/linux/config.h && echo yes),yes)
++ CPPFLAGS += -DHAVE_LINUX_CONFIG_H
++endif
++
+ .PHONY: all install clean
+
+ all: