summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libgweather/libgweather-3.8.2.ebuild')
-rw-r--r--dev-libs/libgweather/libgweather-3.8.2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-libs/libgweather/libgweather-3.8.2.ebuild b/dev-libs/libgweather/libgweather-3.8.2.ebuild
new file mode 100644
index 000000000000..b803d8b9cfa8
--- /dev/null
+++ b/dev-libs/libgweather/libgweather-3.8.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgweather/libgweather-3.8.2.ebuild,v 1.1 2013/05/13 20:48:14 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="Library to access weather information from online services"
+HOMEPAGE="https://live.gnome.org/LibGWeather"
+
+LICENSE="GPL-2+"
+SLOT="2/3-3" # subslot = 3-(libgweather-3 soname suffix)
+IUSE="+introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+
+# libsoup-gnome is to be used because libsoup[gnome] might not
+# get libsoup-gnome installed by the time ${P} is built
+COMMON_DEPEND="
+ >=x11-libs/gtk+-2.90.0:3[introspection?]
+ >=dev-libs/glib-2.35.1:2
+ || ( >=net-libs/libsoup-2.42:2.4 >=net-libs/libsoup-gnome-2.34:2.4 )
+ >=dev-libs/libxml2-2.6.0
+ >=sys-libs/timezone-data-2010k
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-base/gnome-applets-2.22.0
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.50
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS"
+ # Do not add --disable-all-translations-in-one-xml : it will enable them
+ gnome2_src_configure \
+ --enable-locations-compression \
+ --disable-static \
+ $(use_enable introspection)
+}