summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/dbus-glib/dbus-glib-0.71.ebuild')
-rw-r--r--dev-libs/dbus-glib/dbus-glib-0.71.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-libs/dbus-glib/dbus-glib-0.71.ebuild b/dev-libs/dbus-glib/dbus-glib-0.71.ebuild
new file mode 100644
index 000000000000..d569b70cce86
--- /dev/null
+++ b/dev-libs/dbus-glib/dbus-glib-0.71.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dbus-glib/dbus-glib-0.71.ebuild,v 1.1 2006/08/18 22:09:48 steev Exp $
+
+inherit eutils multilib debug autotools
+
+DESCRIPTION="D-Bus bindings for glib"
+HOMEPAGE="http://dbus.freedesktop.org/"
+SRC_URI="http://dbus.freedesktop.org/releases/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="|| ( GPL-2 AFL-2.1 )"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc selinux"
+
+RDEPEND=">=sys-apps/dbus-core-0.91
+ >=dev-libs/glib-2.4
+ selinux? ( sys-libs/libselinux )
+ >=dev-libs/libxml2-2.6.21"
+ # expat code now sucks.. libxml2 is the default
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen
+ app-text/xmlto )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-introspection.patch
+}
+
+src_compile() {
+ local myconf=""
+
+ econf \
+ $(use_enable selinux) \
+ $(use_enable debug verbose-mode) \
+ $(use_enable debug checks) \
+ $(use_enable debug asserts) \
+ --with-xml=libxml \
+ --with-system-pid-file=/var/run/dbus.pid \
+ --with-system-socket=/var/run/dbus/system_bus_socket \
+ --with-session-socket-dir=/tmp \
+ --with-dbus-user=messagebus \
+ --localstatedir=/var \
+ $(use_enable doc doxygen-docs) \
+ --disable-xml-docs \
+ ${myconf} \
+ || die "econf failed"
+
+ # after the compile, it uses a selinuxfs interface to
+ # check if the SELinux policy has the right support
+ use selinux && addwrite /selinux/access
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ dodoc AUTHORS ChangeLog HACKING NEWS README
+}