summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/gnu-smalltalk/gnu-smalltalk-2.3.1.ebuild')
-rw-r--r--dev-lang/gnu-smalltalk/gnu-smalltalk-2.3.1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-lang/gnu-smalltalk/gnu-smalltalk-2.3.1.ebuild b/dev-lang/gnu-smalltalk/gnu-smalltalk-2.3.1.ebuild
index b6d94d2e788f..e1ed64717b56 100644
--- a/dev-lang/gnu-smalltalk/gnu-smalltalk-2.3.1.ebuild
+++ b/dev-lang/gnu-smalltalk/gnu-smalltalk-2.3.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/gnu-smalltalk-2.3.1.ebuild,v 1.2 2006/12/18 10:29:20 araujo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/gnu-smalltalk-2.3.1.ebuild,v 1.3 2006/12/25 20:02:52 araujo Exp $
-inherit elisp-common flag-o-matic eutils toolchain-funcs
+inherit multilib elisp-common flag-o-matic eutils toolchain-funcs
DESCRIPTION="GNU Smalltalk"
HOMEPAGE="http://www.gnu.org/software/smalltalk/smalltalk.html"
@@ -40,8 +40,8 @@ src_compile() {
`use_with emacs emacs` \
`use_with readline readline` \
`use_with gmp gmp` \
- `use_with tk tcl /usr/lib` \
- `use_with tk tk /usr/lib` \
+ `use_with tk tcl /usr/$(get_libdir)` \
+ `use_with tk tk /usr/$(get_libdir)` \
`use_enable gtk gtk` \
|| die
emake || die "emake failed"