summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/resin-servlet-api/files/resin-3.0.24-gentoo.patch')
-rw-r--r--dev-java/resin-servlet-api/files/resin-3.0.24-gentoo.patch283
1 files changed, 0 insertions, 283 deletions
diff --git a/dev-java/resin-servlet-api/files/resin-3.0.24-gentoo.patch b/dev-java/resin-servlet-api/files/resin-3.0.24-gentoo.patch
deleted file mode 100644
index 6b54c07b4218..000000000000
--- a/dev-java/resin-servlet-api/files/resin-3.0.24-gentoo.patch
+++ /dev/null
@@ -1,283 +0,0 @@
-diff -Nru resin-3.0.24.vanilla/Makefile.in resin-3.0.24/Makefile.in
---- resin-3.0.24.vanilla/Makefile.in 2006-08-01 12:48:26.000000000 +0200
-+++ resin-3.0.24/Makefile.in 2007-08-17 09:12:32.000000000 +0200
-@@ -1,6 +1,6 @@
- PREFIX=@prefix@
-
--all :
-+all :
- (cd modules/c/src; $(MAKE))
-
- clean :
-@@ -8,20 +8,20 @@
-
- install :
- (cd modules/c/src; $(MAKE) install)
-- if test $(PREFIX) != `pwd`; then \
-- mkdir -p $(PREFIX)/lib; \
-- mkdir -p $(PREFIX)/libexec; \
-- cp -r libexec/* $(PREFIX)/libexec; \
-- cp lib/*.jar $(PREFIX)/lib; \
-- mkdir -p $(PREFIX)/bin; \
-- cp bin/* $(PREFIX)/bin; \
-- mkdir -p $(PREFIX)/webapps; \
-- cp -r webapps/* $(PREFIX)/webapps; \
-- mkdir -p $(PREFIX)/conf; \
-- cp conf/resin.conf $(PREFIX)/conf/resin.conf.orig; \
-- cp conf/app-default.xml $(PREFIX)/conf/app-default.xml.orig; \
-- if test ! -r $(PREFIX)/conf/resin.conf; then \
-- cp conf/resin.conf $(PREFIX)/conf/resin.conf; \
-- cp conf/app-default.xml $(PREFIX)/conf/app-default.xml; \
-+ if test $(DESTDIR)$(PREFIX) != `pwd`; then \
-+ mkdir -p $(DESTDIR)$(PREFIX)/lib; \
-+ mkdir -p $(DESTDIR)$(PREFIX)/libexec; \
-+ cp -r libexec/* $(DESTDIR)$(PREFIX)/libexec; \
-+ cp lib/*.jar $(DESTDIR)$(PREFIX)/lib; \
-+ mkdir -p $(DESTDIR)$(PREFIX)/bin; \
-+ cp bin/* $(DESTDIR)$(PREFIX)/bin; \
-+ mkdir -p $(DESTDIR)$(PREFIX)/webapps; \
-+ cp -r webapps/* $(DESTDIR)$(PREFIX)/webapps; \
-+ mkdir -p $(DESTDIR)$(PREFIX)/conf; \
-+ cp conf/resin.conf $(DESTDIR)$(PREFIX)/conf/resin.conf.orig; \
-+ cp conf/app-default.xml $(DESTDIR)$(PREFIX)/conf/app-default.xml.orig; \
-+ if test ! -r $(DESTDIR)$(PREFIX)/conf/resin.conf; then \
-+ cp conf/resin.conf $(DESTDIR)$(PREFIX)/conf/resin.conf; \
-+ cp conf/app-default.xml $(DESTDIR)$(PREFIX)/conf/app-default.xml; \
- fi; \
- fi
-diff -Nru resin-3.0.24.vanilla/bin/wrapper.pl resin-3.0.24/bin/wrapper.pl
---- resin-3.0.24.vanilla/bin/wrapper.pl 2007-08-14 08:56:36.000000000 +0200
-+++ resin-3.0.24/bin/wrapper.pl 2007-08-17 09:12:32.000000000 +0200
-@@ -447,9 +447,6 @@
- $pid=`cat $pid_file`;
- chop($pid);
-
-- if ($cmd eq "stop") {
-- print("Stopping ${name}\n");
-- }
- $signal = 15;
- $count = 10;
- while (kill($signal, $pid) && $count-- > 0) {
-@@ -565,8 +562,6 @@
- $SIG{CHLD} = 'IGNORE';
- }
-
-- print "\n\nResin wrapper.pl closing.\n\n";
--
- close(S);
- close(C); # closing the accepted socket should start orderly shutdown
- # unlink needs to happen relatively soon so restart's pid won't
-@@ -743,8 +738,6 @@
- $date = `date`;
- chop($date);
-
-- print "Resin $name $cmd at $date\n";
--
- # create a keepalive socket
- # when the wrapper dies, the httpd class will detect that and
- # close gracefully
-diff -Nru resin-3.0.24.vanilla/bin/wrapper.pl.in resin-3.0.24/bin/wrapper.pl.in
---- resin-3.0.24.vanilla/bin/wrapper.pl.in 2007-01-01 11:02:08.000000000 +0100
-+++ resin-3.0.24/bin/wrapper.pl.in 2007-08-17 09:12:32.000000000 +0200
-@@ -447,9 +447,6 @@
- $pid=`cat $pid_file`;
- chop($pid);
-
-- if ($cmd eq "stop") {
-- print("Stopping ${name}\n");
-- }
- $signal = 15;
- $count = 10;
- while (kill($signal, $pid) && $count-- > 0) {
-@@ -565,8 +562,6 @@
- $SIG{CHLD} = 'IGNORE';
- }
-
-- print "\n\nResin wrapper.pl closing.\n\n";
--
- close(S);
- close(C); # closing the accepted socket should start orderly shutdown
- # unlink needs to happen relatively soon so restart's pid won't
-@@ -743,8 +738,6 @@
- $date = `date`;
- chop($date);
-
-- print "Resin $name $cmd at $date\n";
--
- # create a keepalive socket
- # when the wrapper dies, the httpd class will detect that and
- # close gracefully
-diff -Nru resin-3.0.24.vanilla/build.xml resin-3.0.24/build.xml
---- resin-3.0.24.vanilla/build.xml 2006-11-01 09:59:02.000000000 +0100
-+++ resin-3.0.24/build.xml 2007-08-17 09:12:32.000000000 +0200
-@@ -7,7 +7,6 @@
-
- <property name="modules" location="${basedir}/modules"/>
- <property name="src" location="${basedir}/src"/>
-- <property name="ext" location="${basedir}/modules/ext"/>
- <property name="doc" location="${basedir}/doc"/>
-
- <property name="build" location="${install}/build"/>
-@@ -17,14 +16,12 @@
-
-
- <property name="javac.verbose" value="off"/>
-- <property name="javac.debug" value="on"/>
-+ <property name="javac.debug" value="off"/>
- <property name="javac.optimize" value="off"/>
- <property name="javac.deprecation" value="off"/>
- <property name="javac.nowarn" value="on"/>
- <property name="javac.memoryMaximumSize" value="256m"/>
-
-- <property name="javac.source" value="1.4"/>
--
- <property name="jar.compress" value="false"/>
- <property name="jar.index" value="true"/>
- <property name="jar.update" value="false"/>
-@@ -66,7 +63,7 @@
- </target>
-
- <target name="compile"
-- depends="init, ejb, ejb30, j2ee-deploy, j2ee-management, jaxrpc, jca, jms, jmx, jsdk, jstl, jta, portlet, script, resin-jdk15, resin, quercus, webutil, deploy, conf, ext">
-+ depends="init, ejb, ejb30, j2ee-deploy, j2ee-management, jaxrpc, jca, jms, jmx, jstl, jta, portlet, script, resin-jdk15, resin, quercus, webutil, deploy, conf">
- </target>
-
- <target name="ejb" depends="init, jta">
-@@ -80,7 +77,6 @@
- <antcall target="module" inheritRefs="true">
- <param name="module.name" value="ejb30"/>
- <param name="module.jar" value="ejb-30.jar"/>
-- <param name="javac.source" value="1.5"/>
- </antcall>
- </target>
-
-@@ -98,11 +94,10 @@
- </antcall>
- </target>
-
-- <target name="jaxrpc" depends="init,saaj,jsdk">
-+ <target name="jaxrpc" depends="init,saaj">
- <antcall target="module" inheritRefs="true">
- <param name="module.name" value="jaxrpc"/>
- <param name="module.jar" value="jaxrpc.jar"/>
-- <param name="javac.source" value="1.5"/>
- </antcall>
- </target>
-
-@@ -116,7 +111,6 @@
- <target name="resin-jdk15" depends="init">
- <antcall target="module" inheritRefs="true">
- <param name="module.name" value="resin-jdk15"/>
-- <param name="javac.source" value="1.5"/>
- </antcall>
- </target>
-
-@@ -148,7 +142,7 @@
- </antcall>
- </target>
-
-- <target name="jstl" depends="init, jsdk">
-+ <target name="jstl" depends="init">
- <antcall target="module" inheritRefs="true">
- <param name="module.name" value="jstl"/>
- <param name="module.jar" value="jstl-11.jar"/>
-@@ -187,7 +181,7 @@
- </antcall>
- </target>
-
-- <target name="resin-dev" depends="init, ejb, ejb30, jca, jcr, jms, jmx, jsdk, jstl, jta, j2ee-deploy, j2ee-management, saaj, jaxrpc, portlet, script, resin-jdk15">
-+ <target name="resin-dev" depends="init, ejb, ejb30, jca, jcr, jms, jmx, jstl, jta, j2ee-deploy, j2ee-management, saaj, jaxrpc, portlet, script, resin-jdk15">
-
- <!-- filter to insert version -->
-
-@@ -217,7 +211,6 @@
-
- <antcall target="module" inheritRefs="true">
- <param name="module.name" value="resin"/>
-- <param name="javac.source" value="1.5"/>
- </antcall>
- </target>
-
-@@ -242,14 +235,12 @@
- <target name="webutil" depends="init, resin">
- <antcall target="module" inheritRefs="true">
- <param name="module.name" value="webutil"/>
-- <param name="javac.source" value="1.5"/>
- </antcall>
- </target>
-
- <target name="quercus-dev" depends="init">
- <antcall target="module" inheritRefs="true">
- <param name="module.name" value="quercus"/>
-- <param name="javac.source" value="1.5"/>
- </antcall>
- </target>
-
-@@ -282,16 +273,15 @@
- verbose="${javac.verbose}"
- debug="${javac.debug}" optimize="${javac.optimize}"
- deprecation="${javac.deprecation}" nowarn="${javac.nowarn}"
-- source="${javac.source}"
- excludes="**/.svn/**"
- memoryMaximumSize="${javac.memoryMaximumSize}">
- <classpath>
- <dirset dir="${modules}">
- <include name="*/classes"/>
- </dirset>
-- <fileset dir="${ext}">
-- <include name="**/*.jar"/>
-- </fileset>
-+ <fileset dir="lib">
-+ <include name="*.jar" />
-+ </fileset>
- </classpath>
- </javac>
-
-@@ -358,13 +348,6 @@
- </copy>
- </target>
-
-- <target name="ext" depends="init, resin">
-- <copy todir="${install}/lib" preservelastmodified="true">
-- <fileset dir="${ext}">
-- </fileset>
-- </copy>
-- </target>
--
- <target name="webapps" depends="init, doc, quercus">
- </target>
-
-@@ -503,9 +486,6 @@
- <dirset dir="${modules}">
- <include name="*/classes"/>
- </dirset>
-- <fileset dir="${modules}/ext">
-- <include name="**/*.jar"/>
-- </fileset>
- </classpath>
- </java>
-
-@@ -688,7 +668,6 @@
- <include name="lib/jca-15.jar"/>
- <include name="lib/jms-11.jar"/>
- <include name="lib/jmx-12.jar"/>
-- <include name="lib/jsdk-24.jar"/>
- <include name="lib/jstl-11.jar"/>
- <include name="lib/jta-101.jar"/>
- <include name="lib/portlet-10.jar"/>
-diff -Nru resin-3.0.24.vanilla/modules/resin/src/com/caucho/server/resin/Resin.java resin-3.0.24/modules/resin/src/com/caucho/server/resin/Resin.java
---- resin-3.0.24.vanilla/modules/resin/src/com/caucho/server/resin/Resin.java 2006-08-01 12:43:54.000000000 +0200
-+++ resin-3.0.24/modules/resin/src/com/caucho/server/resin/Resin.java 2007-08-17 09:12:32.000000000 +0200
-@@ -700,10 +700,10 @@
- throw new ConfigException(L().l("The following system property must be set:\n -Djava.util.logging.manager=com.caucho.log.LogManagerImpl\nThe JDK 1.4 Logging manager must be set to Resin's log manager."));
- }
-
-- validatePackage("javax.servlet.Servlet", new String[] {"2.4", "1.4"});
-+ validatePackage("javax.servlet.Servlet", new String[] {"2.4", "1.5"});
- validatePackage("javax.servlet.jsp.jstl.core.Config", new String[] {"1.1"});
- validatePackage("javax.management.MBeanServer", new String[] { "1.2", "1.5" });
-- validatePackage("javax.resource.spi.ResourceAdapter", new String[] {"1.5", "1.4"});
-+ validatePackage("javax.resource.spi.ResourceAdapter", new String[] {"1.5", "1.5"});
- }
-
- /**