summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/plugspud/plugspud-0.4.5.20040917.ebuild')
-rw-r--r--dev-java/plugspud/plugspud-0.4.5.20040917.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-java/plugspud/plugspud-0.4.5.20040917.ebuild b/dev-java/plugspud/plugspud-0.4.5.20040917.ebuild
new file mode 100644
index 000000000000..aa476f5af0d3
--- /dev/null
+++ b/dev-java/plugspud/plugspud-0.4.5.20040917.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/plugspud/plugspud-0.4.5.20040917.ebuild,v 1.1 2004/09/17 09:28:58 axxo Exp $
+
+inherit java-pkg
+
+DESCRIPTION="plugspud is something Gruntspud needs."
+HOMEPAGE="http://gruntspud.sourceforge.net/"
+SRC_URI="mirror://gentoo/plugspud-gentoo-cvs-20040917.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="jikes"
+DEPEND=">=virtual/jdk-1.3
+ dev-java/ant
+ jikes? ( dev-java/jikes )"
+RDEPEND=">=virtual/jre-1.3"
+
+S=${WORKDIR}/plugspud
+
+src_compile() {
+ local antflags=""
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ ant dist ${antflags} || die "compilation failed"
+}
+
+src_install() {
+ java-pkg_dojar dist/lib/plugspud.jar
+}