summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/gnomemm/gnomemm-1.2.3-r1.ebuild')
-rw-r--r--dev-cpp/gnomemm/gnomemm-1.2.3-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-cpp/gnomemm/gnomemm-1.2.3-r1.ebuild b/dev-cpp/gnomemm/gnomemm-1.2.3-r1.ebuild
new file mode 100644
index 000000000000..fb6470bce44c
--- /dev/null
+++ b/dev-cpp/gnomemm/gnomemm-1.2.3-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gnomemm/gnomemm-1.2.3-r1.ebuild,v 1.1 2003/06/20 23:44:44 liquidx Exp $
+
+inherit gcc
+
+S=${WORKDIR}/${P}
+DESCRIPTION="C++ binding for the GNOME libraries"
+SRC_URI="mirror://sourceforge/gtkmm/${P}.tar.gz"
+HOMEPAGE="http://gtkmm.sourceforge.net/"
+
+IUSE=""
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="x86 sparc alpha"
+
+RDEPEND="=x11-libs/gtkmm-1.2*
+ >=gnome-base/ORBit-0.5.11
+ =sys-libs/db-1*"
+
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ econf
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING ChangeLog NEWS README* TODO
+}