summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/pylize/pylize-1.3b.ebuild')
-rw-r--r--app-text/pylize/pylize-1.3b.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-text/pylize/pylize-1.3b.ebuild b/app-text/pylize/pylize-1.3b.ebuild
new file mode 100644
index 000000000000..0c8f4e6196f3
--- /dev/null
+++ b/app-text/pylize/pylize-1.3b.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pylize/pylize-1.3b.ebuild,v 1.1 2005/12/18 23:34:44 lucass Exp $
+
+inherit python
+
+DESCRIPTION="Python HTML Slideshow Generator using HTML and CSS"
+HOMEPAGE="http://www.chrisarndt.de/en/software/pylize/"
+SRC_URI="http://www.chrisarndt.de/en/software/pylize/download/${P}.tar.bz2"
+
+IUSE=""
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+
+DEPEND="virtual/python
+ dev-python/empy
+ dev-python/imaging"
+
+src_compile() {
+ einfo "no need to compile"
+}
+
+src_install() {
+ python install.py ${D}/usr || die
+
+ # Fix Data dir in code
+ sed -e "s:^sys_libdir.*:sys_libdir = \'/usr/share/pylize\':" -i ${D}/usr/bin/pylize
+
+ python_version
+ insinto /usr/lib/python${PYVER}/site-packages
+ doins lib/roman.py
+
+ dodoc COPYING Changelog README README.empy TODO
+}