summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/dictd/dictd-1.9.14.ebuild')
-rw-r--r--app-text/dictd/dictd-1.9.14.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-text/dictd/dictd-1.9.14.ebuild b/app-text/dictd/dictd-1.9.14.ebuild
new file mode 100644
index 000000000000..e221b660e3a2
--- /dev/null
+++ b/app-text/dictd/dictd-1.9.14.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/dictd/dictd-1.9.14.ebuild,v 1.1 2004/09/21 23:48:17 liquidx Exp $
+
+inherit gnuconfig
+
+DESCRIPTION="Dictionary Client/Server for the DICT protocol"
+HOMEPAGE="http://www.dict.org/"
+SRC_URI="mirror://sourceforge/dict/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~amd64 ~ia64 ~ppc64"
+IUSE=""
+
+DEPEND="virtual/libc"
+
+src_compile() {
+
+ # Update config.sub and config.guess so dictd understands the sparc architecture
+ gnuconfig_update
+
+ econf \
+ --with-cflags="${CFLAGS}" \
+ --sysconfdir=/etc/dict || die
+ make || die
+}
+
+src_install() {
+ # Now install it.
+ make DESTDIR=${D} install || die "install failed"
+
+ # Install docs
+ dodoc README TODO COPYING ChangeLog ANNOUNCE
+ dodoc doc/dicf.ms doc/rfc.ms doc/rfc.sh doc/rfc2229.txt
+ dodoc doc/security.doc doc/toc.ms
+
+ # conf files.
+ dodir /etc/dict
+ insinto /etc/dict
+ doins ${FILESDIR}/${PVR}/dict.conf
+ doins ${FILESDIR}/${PVR}/dictd.conf
+ doins ${FILESDIR}/${PVR}/site.info
+
+ # startups for dictd
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/${PVR}/dictd dictd
+ insinto /etc/conf.d
+ newins ${FILESDIR}/${PVR}/dictd.confd dictd
+}