summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/bash/bash-2.05b-r4.ebuild')
-rw-r--r--app-shells/bash/bash-2.05b-r4.ebuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/app-shells/bash/bash-2.05b-r4.ebuild b/app-shells/bash/bash-2.05b-r4.ebuild
new file mode 100644
index 000000000000..274e071e3a77
--- /dev/null
+++ b/app-shells/bash/bash-2.05b-r4.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-2.05b-r4.ebuild,v 1.1 2003/04/27 11:12:10 azarah Exp $
+
+inherit eutils flag-o-matic
+
+# Official patches
+PLEVEL="x002 x003 x004"
+
+DESCRIPTION="The standard GNU Bourne again shell"
+SRC_URI="ftp://ftp.gnu.org/gnu/bash/${P}.tar.gz
+ mirror://gentoo/${P}-gentoo.diff.bz2
+ ${PLEVEL//x/ftp://ftp.gnu.org/gnu/bash/bash-${PV}-patches/bash${PV/\.}-}"
+HOMEPAGE="http://www.gnu.org/software/bash/bash.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm"
+IUSE="nls build"
+
+DEPEND=">=sys-libs/ncurses-5.2-r2"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ cd ${S}
+ epatch ${DISTDIR}/${P}-gentoo.diff.bz2
+
+ for x in ${PLEVEL//x}
+ do
+ epatch ${DISTDIR}/${PN}${PV/\.}-${x}
+ done
+
+ # Remove autoconf dependency
+ cp Makefile.in Makefile.in.orig
+ sed -e "/&& autoconf/d" Makefile.in.orig > Makefile.in
+
+ # Readline is slow with multibyte locale, bug #19762
+ epatch ${FILESDIR}/${P}-multibyte-locale.patch
+}
+
+src_compile() {
+
+ filter-flags -malign-double
+
+ local myconf=""
+
+ # Always use the buildin readline, else if we update readline
+ # bash gets borked as readline is usually not binary compadible
+ # between minor versions.
+ #
+ # Martin Schlemmer <azarah@gentoo.org> (1 Sep 2002)
+ #use readline && myconf="--with-installed-readline"
+ #use static && export LDFLAGS="${LDFLAGS} -static"
+ use nls || myconf="${myconf} --disable-nls"
+
+ econf \
+ --disable-profiling \
+ --with-curses \
+ --without-gnu-malloc \
+ ${myconf} || die
+
+ make || die
+}
+
+src_install() {
+ einstall || die
+
+ dodir /bin
+ mv ${D}/usr/bin/bash ${D}/bin
+ dosym bash /bin/sh
+
+ use build \
+ && rm -rf ${D}/usr \
+ || ( \
+ doman doc/*.1
+ dodoc README NEWS AUTHORS CHANGES COMPAT COPYING Y2K
+ dodoc doc/FAQ doc/INTRO
+ )
+}