summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-pda/libopensync/libopensync-9999.ebuild')
-rw-r--r--app-pda/libopensync/libopensync-9999.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/app-pda/libopensync/libopensync-9999.ebuild b/app-pda/libopensync/libopensync-9999.ebuild
index cc112f63fd2c..145fd6278131 100644
--- a/app-pda/libopensync/libopensync-9999.ebuild
+++ b/app-pda/libopensync/libopensync-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync/libopensync-9999.ebuild,v 1.1 2007/11/26 20:12:07 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync/libopensync-9999.ebuild,v 1.2 2007/12/21 23:02:25 peper Exp $
inherit cmake-utils eutils subversion
@@ -38,13 +38,19 @@ src_compile() {
mycmakeargs="${mycmakeargs} -DBUILD_DOCUMENTATION=$(use doc && echo ON || echo OFF)"
cmake-utils_src_compile
- use doc && doxygen Doxyfile
+ if use doc ; then
+ cd "${WORKDIR}/${PN}_build"
+ doxygen Doxyfile || die "Failed to generate docs."
+ fi
}
src_install() {
cmake-utils_src_install
- use doc && dohtml docs/html/*
+ if use doc ; then
+ cd "${WORKDIR}/${PN}_build"
+ dohtml docs/html/* || die "Failed to install docs."
+ fi
}
pkg_postinst() {