summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/openoffice/files')
-rw-r--r--app-office/openoffice/files/1.1.1/newstlportfix.patch269
-rw-r--r--app-office/openoffice/files/1.1.1/nptl.patch42
-rw-r--r--app-office/openoffice/files/1.1.1/ooffice-wrapper-1.3280
-rw-r--r--app-office/openoffice/files/1.1.1/openoffice-java.patch36
-rw-r--r--app-office/openoffice/files/digest-openoffice-1.1.12
5 files changed, 629 insertions, 0 deletions
diff --git a/app-office/openoffice/files/1.1.1/newstlportfix.patch b/app-office/openoffice/files/1.1.1/newstlportfix.patch
new file mode 100644
index 000000000000..dc958c84a6f8
--- /dev/null
+++ b/app-office/openoffice/files/1.1.1/newstlportfix.patch
@@ -0,0 +1,269 @@
+diff -urN stlport.orig/STLport-4.5.3.patch stlport/STLport-4.5.3.patch
+--- stlport.orig/STLport-4.5.3.patch 1970-01-01 01:00:00.000000000 +0100
++++ stlport/STLport-4.5.3.patch 2004-02-08 11:52:28.424007600 +0100
+@@ -0,0 +1,247 @@
++*** misc/STLport-4.5.3/src/fstream.cpp Tue Sep 4 19:10:12 2001
++--- misc/build/STLport-4.5.3/src/fstream.cpp Fri Jan 11 17:22:40 2002
++***************
++*** 293,299 ****
++ #ifdef __MINGW32__
++ __MINGW_IMPORT ioinfo * __pioinfo[];
++ #else
++! extern _CRTIMP ioinfo * __pioinfo[];
++ #endif
++
++ } // extern "C"
++--- 293,299 ----
++ #ifdef __MINGW32__
++ __MINGW_IMPORT ioinfo * __pioinfo[];
++ #else
++! extern __declspec( dllimport ) ioinfo * __pioinfo[];
++ #endif
++
++ } // extern "C"
++*** misc/STLport-4.5.3/src/gcc-3.0.mak Fri Jan 11 12:48:44 2002
++--- misc/build/STLport-4.5.3/src/gcc-3.0.mak Fri Jan 11 12:47:21 2002
++***************
++*** 1 ****
++! dummy
++--- 1,59 ----
++! #
++! # Note : this makefile is for gcc-3 !
++! #
++!
++! #
++! # compiler
++! #
++! CC = $(CCCOMP)
++! CXX = $(CXXCOMP) -D_REENTRANT -fexceptions
++!
++! #
++! # Basename for libraries
++! #
++! LIB_BASENAME = libstlport_gcc
++!
++! #
++! # guts for common stuff
++! #
++! #
++! LINK=ar cr
++! DYN_LINK=$(CXX) --fexceptions -shared -o
++!
++! OBJEXT=o
++! DYNEXT=so
++! STEXT=a
++! RM=rm -rf
++! PATH_SEP=/
++! MKDIR=mkdir -p
++! COMP=GCC$(ARCH)
++! INSTALL_STEP = install_unix
++!
++! all: all_dynamic all_static symbolic_links
++!
++! include common_macros.mak
++!
++! WARNING_FLAGS= -Wall -W -Wno-sign-compare -Wno-unused -Wno-uninitialized -ftemplate-depth-32
++!
++! CXXFLAGS_COMMON = -I${STLPORT_DIR} ${WARNING_FLAGS}
++!
++! CXXFLAGS_RELEASE_static = $(CXXFLAGS_COMMON) -O2 -fPIC
++! CXXFLAGS_RELEASE_dynamic = $(CXXFLAGS_COMMON) -O2 -fPIC
++!
++! CXXFLAGS_DEBUG_static = $(CXXFLAGS_COMMON) -g -fPIC
++! CXXFLAGS_DEBUG_dynamic = $(CXXFLAGS_COMMON) -g -fPIC
++!
++! CXXFLAGS_STLDEBUG_static = $(CXXFLAGS_DEBUG_static) -D_STLP_DEBUG
++! CXXFLAGS_STLDEBUG_dynamic = $(CXXFLAGS_DEBUG_dynamic) -D_STLP_DEBUG
++!
++! include common_percent_rules.mak
++! include common_rules.mak
++!
++!
++! #install: all
++! # cp -p $(LIB_TARGET) ${D_LIB_TARGET} ../lib
++!
++! #%.s: %.cpp
++! # $(CXX) $(CXXFLAGS) -O4 -S -pto $< -o $@
++!
++!
++*** misc/STLport-4.5.3/src/vc6.mak Mon Jul 30 00:18:15 2001
++--- misc/build/STLport-4.5.3/src/vc6.mak Fri Jan 11 17:41:08 2002
++***************
++*** 10,16 ****
++ COMP=VC6
++
++ # EXTRA_COMMON_FLAGS=/D "_MBCS"
++! EXTRA_COMMON_FLAGS=/Zm800 /FI "vc_warning_disable.h" /D "_MBCS"
++ EXTRA_DEBUG_FLAGS=
++ EXTRA_NDEBUG_FLAGS=
++
++--- 10,16 ----
++ COMP=VC6
++
++ # EXTRA_COMMON_FLAGS=/D "_MBCS"
++! EXTRA_COMMON_FLAGS=/Zm800 /FI "vc_warning_disable.h" /D "_MBCS" /D "_NTSDK" /D "_CRTIMP="
++ EXTRA_DEBUG_FLAGS=
++ EXTRA_NDEBUG_FLAGS=
++
++*** misc/STLport-4.5.3/src/vc_common.mak Tue Sep 4 19:10:12 2001
++--- misc/build/STLport-4.5.3/src/vc_common.mak Fri Jan 11 12:48:14 2002
++***************
++*** 62,68 ****
++ LDFLAGS_RELEASE=/opt:ref
++
++ LDFLAGS_COMMON_static=$(LDFLAGS_COMMON)
++! LDFLAGS_COMMON_dynamic=$(LDFLAGS_COMMON) /dll /incremental:no
++
++
++ CXXFLAGS_DEBUG_static=$(FLAGS_COMMON_static) /MTd $(FLAGS_DEBUG) /Fo"$(DEBUG_OBJDIR_static)\\" /Fd"$(DEBUG_OBJDIR_static)\\" /YXstlport_prefix.h /Fp$(DEBUG_OBJDIR_static)\stlport.pch
++--- 62,68 ----
++ LDFLAGS_RELEASE=/opt:ref
++
++ LDFLAGS_COMMON_static=$(LDFLAGS_COMMON)
++! LDFLAGS_COMMON_dynamic=$(LDFLAGS_COMMON) /nodefaultlib oldnames.lib kernel32.lib /dll /incremental:no
++
++
++ CXXFLAGS_DEBUG_static=$(FLAGS_COMMON_static) /MTd $(FLAGS_DEBUG) /Fo"$(DEBUG_OBJDIR_static)\\" /Fd"$(DEBUG_OBJDIR_static)\\" /YXstlport_prefix.h /Fp$(DEBUG_OBJDIR_static)\stlport.pch
++***************
++*** 79,87 ****
++
++
++ LDFLAGS_DEBUG_static=$(LDFLAGS_COMMON_static)
++! LDFLAGS_DEBUG_dynamic=$(LDFLAGS_COMMON_dynamic) $(LDFLAGS_DEBUG) /implib:"$(OUTDIR)\$(DEBUG_NAME).$(STEXT)"
++ LDFLAGS_STLDEBUG_static=$(LDFLAGS_COMMON_static)
++! LDFLAGS_STLDEBUG_dynamic=$(LDFLAGS_COMMON_dynamic) $(LDFLAGS_DEBUG) /implib:"$(OUTDIR)\$(STLDEBUG_NAME).$(STEXT)"
++
++ # LDFLAGS_DEBUG_static=$(LDFLAGS_COMMON_static) /DEBUGTYPE:CV
++ # LDFLAGS_DEBUG_dynamic=$(LDFLAGS_COMMON_dynamic) /DEBUG /DEBUGTYPE:CV /implib:"$(OUTDIR)\$(DEBUG_NAME).$(STEXT)"
++--- 79,87 ----
++
++
++ LDFLAGS_DEBUG_static=$(LDFLAGS_COMMON_static)
++! LDFLAGS_DEBUG_dynamic=$(LDFLAGS_COMMON_dynamic) msvcrtd.lib $(LDFLAGS_DEBUG) /implib:"$(OUTDIR)\$(DEBUG_NAME).$(STEXT)"
++ LDFLAGS_STLDEBUG_static=$(LDFLAGS_COMMON_static)
++! LDFLAGS_STLDEBUG_dynamic=$(LDFLAGS_COMMON_dynamic) msvcrtd.lib $(LDFLAGS_DEBUG) /implib:"$(OUTDIR)\$(STLDEBUG_NAME).$(STEXT)"
++
++ # LDFLAGS_DEBUG_static=$(LDFLAGS_COMMON_static) /DEBUGTYPE:CV
++ # LDFLAGS_DEBUG_dynamic=$(LDFLAGS_COMMON_dynamic) /DEBUG /DEBUGTYPE:CV /implib:"$(OUTDIR)\$(DEBUG_NAME).$(STEXT)"
++***************
++*** 95,101 ****
++ CXXFLAGS_RELEASE_dynamic=$(FLAGS_COMMON_dynamic) /MD $(FLAGS_NDEBUG) /Fo"$(RELEASE_OBJDIR_dynamic)\\" /Fd"$(RELEASE_OBJDIR_dynamic)\\" /YXstlport_prefix.h /Fp$(RELEASE_OBJDIR_dynamic)\stlport.pch
++
++ LDFLAGS_RELEASE_static=$(LDFLAGS_COMMON_static)
++! LDFLAGS_RELEASE_dynamic=$(LDFLAGS_COMMON_dynamic) $(LDFLAGS_RELEASE) /implib:"$(OUTDIR)\$(RELEASE_NAME).$(STEXT)"
++ # LDFLAGS_RELEASE_dynamic=$(LDFLAGS_COMMON_dynamic) /implib:"$(OUTDIR)\$(RELEASE_NAME).$(STEXT)"
++
++ RESFILE=$(RELEASE_OBJDIR_dynamic)$(PATH_SEP)stlport.res
++--- 95,101 ----
++ CXXFLAGS_RELEASE_dynamic=$(FLAGS_COMMON_dynamic) /MD $(FLAGS_NDEBUG) /Fo"$(RELEASE_OBJDIR_dynamic)\\" /Fd"$(RELEASE_OBJDIR_dynamic)\\" /YXstlport_prefix.h /Fp$(RELEASE_OBJDIR_dynamic)\stlport.pch
++
++ LDFLAGS_RELEASE_static=$(LDFLAGS_COMMON_static)
++! LDFLAGS_RELEASE_dynamic=$(LDFLAGS_COMMON_dynamic) $(LDFLAGS_RELEASE) msvcrt.lib /implib:"$(OUTDIR)\$(RELEASE_NAME).$(STEXT)"
++ # LDFLAGS_RELEASE_dynamic=$(LDFLAGS_COMMON_dynamic) /implib:"$(OUTDIR)\$(RELEASE_NAME).$(STEXT)"
++
++ RESFILE=$(RELEASE_OBJDIR_dynamic)$(PATH_SEP)stlport.res
++*** misc/STLport-4.5.3/stlport/stdexcept Tue May 22 02:50:21 2001
++--- misc/build/STLport-4.5.3/stlport/stdexcept Mon Jan 14 18:26:09 2002
++***************
++*** 49,54 ****
++--- 49,59 ----
++
++ _STLP_BEGIN_NAMESPACE
++
+++ /* maybe limit to gcc 3.x */
+++ #if defined( __GNUC__)
+++ #define _STLP_NOTHROW_INHERENTLY throw()
+++ #endif
+++
++ class _STLP_CLASS_DECLSPEC __Named_exception : public _STLP_EXCEPTION_BASE {
++ public:
++ __Named_exception(const string& __str)
++*** misc/STLport-4.5.3/stlport/config/stl_gcc.h Thu Jun 6 22:53:04 2002
++--- misc/build/STLport-4.5.3/stlport/config/stl_gcc.h Thu Jun 6 22:53:56 2002
++***************
++*** 226,233 ****
++
++ # if (__GNUC__ >= 3)
++
++! # define _STLP_NATIVE_INCLUDE_PATH ../g++-v3
++! # define _STLP_NATIVE_OLD_STREAMS_INCLUDE_PATH ../g++-v3/backward
++
++ # elif (__GNUC_MINOR__ < 8)
++
++--- 226,233 ----
++
++ # if (__GNUC__ >= 3)
++
++! # define _STLP_NATIVE_INCLUDE_PATH ../g++-v3
++! # define _STLP_NATIVE_OLD_STREAMS_INCLUDE_PATH ../g++-v3/backward
++
++ # elif (__GNUC_MINOR__ < 8)
++
++***************
++*** 285,298 ****
++ # if defined(__DJGPP)
++ # define _STLP_NATIVE_INCLUDE_PATH ../lang/cxx
++ # elif (__GNUC__ >= 3) || (__GNUC_MINOR__ >= 97)
++! # define _STLP_NATIVE_INCLUDE_PATH ../include/g++-v3
++ # elif ((__GNUC_MINOR__ >= 95 && __GNUC_MINOR__ < 97) && !( defined (__FreeBSD__) || defined (__NetBSD__) || defined(__sgi) ) )
++! # define _STLP_NATIVE_INCLUDE_PATH ../g++-3
++ # elif (__GNUC_MINOR__ > 8) && (__GNUC_MINOR__ < 95) && (__GNUC__ < 3) && !defined( __Lynx__ )
++ // this really sucks, as GNUpro does not really identifies itself, so we have to guess
++ // depending on a platform
++ # ifdef __hpux
++! # define _STLP_NATIVE_INCLUDE_PATH ../g++-3
++ # else
++ # define _STLP_NATIVE_INCLUDE_PATH ../g++-2
++ # endif
++--- 285,298 ----
++ # if defined(__DJGPP)
++ # define _STLP_NATIVE_INCLUDE_PATH ../lang/cxx
++ # elif (__GNUC__ >= 3) || (__GNUC_MINOR__ >= 97)
++! # define _STLP_NATIVE_INCLUDE_PATH ../include/g++-v3
++ # elif ((__GNUC_MINOR__ >= 95 && __GNUC_MINOR__ < 97) && !( defined (__FreeBSD__) || defined (__NetBSD__) || defined(__sgi) ) )
++! # define _STLP_NATIVE_INCLUDE_PATH ../g++-v32
++ # elif (__GNUC_MINOR__ > 8) && (__GNUC_MINOR__ < 95) && (__GNUC__ < 3) && !defined( __Lynx__ )
++ // this really sucks, as GNUpro does not really identifies itself, so we have to guess
++ // depending on a platform
++ # ifdef __hpux
++! # define _STLP_NATIVE_INCLUDE_PATH ../g++-v3
++ # else
++ # define _STLP_NATIVE_INCLUDE_PATH ../g++-2
++ # endif
++*** misc/STLport-4.5.3/src/common_rules.mak Tue Sep 10 23:41:05 2002
++--- misc/build/STLport-4.5.3/src/common_rules.mak Tue Sep 10 23:39:45 2002
++***************
++*** 84,90 ****
++ $(RM) $(OUTDIR)/$(STLDEBUG_NAME).$(DYNEXT)
++ $(RM) $(OUTDIR)/$(DEBUG_NAME).$(DYNEXT)
++ ln -s $(RELEASE_DYNLIB) $(OUTDIR)/$(RELEASE_NAME).$(DYNEXT)
++! -ln -s $(DEBUG_DYNLIB) $(OUTDIR)/$(DEBUG_NAME).$(DYNEXT)
++ ln -s $(STLDEBUG_DYNLIB) $(OUTDIR)/$(STLDEBUG_NAME).$(DYNEXT)
++
++ install_unix :
++--- 84,90 ----
++ $(RM) $(OUTDIR)/$(STLDEBUG_NAME).$(DYNEXT)
++ $(RM) $(OUTDIR)/$(DEBUG_NAME).$(DYNEXT)
++ ln -s $(RELEASE_DYNLIB) $(OUTDIR)/$(RELEASE_NAME).$(DYNEXT)
++! -ln -s $(STLDEBUG_DYNLIB) $(OUTDIR)/$(DEBUG_NAME).$(DYNEXT)
++ ln -s $(STLDEBUG_DYNLIB) $(OUTDIR)/$(STLDEBUG_NAME).$(DYNEXT)
++
++ install_unix :
+diff -urN stlport.orig/makefile.mk stlport/makefile.mk
+--- stlport.orig/makefile.mk 2004-01-28 11:52:04.000000000 +0100
++++ stlport/makefile.mk 2004-02-08 12:01:34.362287427 +0100
+@@ -72,11 +72,12 @@
+ # --- Files --------------------------------------------------------
+ .EXPORT : CC CXX
+ .IF "$(COMID)"=="gcc3"
+- TARFILE_NAME=STLport-4.5
+ .IF "$(OS)$(BUILD_OS_MAJOR)$(BUILD_OS_MINOR)"=="MACOSX103"
++ TARFILE_NAME=STLport-4.5
+ PATCH_FILE_NAME=STLport-4.5-macxp-panther.patch
+ .ELSE
+- PATCH_FILE_NAME=STLport-4.5.patch
++ TARFILE_NAME=STLport-4.5.3
++ PATCH_FILE_NAME=STLport-4.5.3.patch
+ .ENDIF
+ .ELSE # "$(COMID)"=="gcc3"
+ .IF "$(OS)"=="MACOSX"
diff --git a/app-office/openoffice/files/1.1.1/nptl.patch b/app-office/openoffice/files/1.1.1/nptl.patch
new file mode 100644
index 000000000000..212ff05c51b6
--- /dev/null
+++ b/app-office/openoffice/files/1.1.1/nptl.patch
@@ -0,0 +1,42 @@
+--- oo_1.1rc3_src/sal/osl/unx/semaphor.c.jj 2003-08-28 10:24:23.736357952 +0100
++++ oo_1.1rc3_src/sal/osl/unx/semaphor.c 2003-08-28 10:24:26.260974152 +0100
+@@ -79,7 +79,7 @@
+ /* osl_createSemaphore */
+ /*****************************************************************************/
+
+-#ifdef LINUX
++#if 0
+ /* sem_t from glibc-2.1 (/usr/include/semaphore.h) */
+
+ typedef struct {
+@@ -100,7 +100,7 @@
+ * larger of both
+ * XXX
+ */
+-#ifdef LINUX
++#if 0
+ if ( sizeof(glibc_21_sem_t) > sizeof(sem_t) )
+ Semaphore= malloc(sizeof(glibc_21_sem_t));
+ else
+--- oo_1.1rc3_src/tools/source/solar/solar.c.jj 2003-08-28 11:50:57.589772216 +0100
++++ oo_1.1rc3_src/tools/source/solar/solar.c 2003-08-28 11:50:05.167741576 +0100
+@@ -577,7 +577,7 @@
+
+ {
+ char* p = NULL;
+- InfoMemoryAccess( p );
++ /*InfoMemoryAccess( p );*/
+ p = (char*)&p;
+ InfoMemoryAccess( p );
+ InfoMemoryTypeAccess( t_short );
+--- oo_1.1_src/neon/neon.patch.jj 2003-10-04 10:32:18.341106008 +0100
++++ oo_1.1_src/neon/neon.patch 2003-10-04 10:32:49.123426384 +0100
+@@ -19,7 +19,7 @@
+ !
+ ! /* Define as __inline if that's what the C compiler calls it. */
+ ! #ifdef UNX
+-! #define inline
++! #define inline inline
+ ! #endif
+ !
+ ! /* Define if you need to in order for stat and other things to work. */
diff --git a/app-office/openoffice/files/1.1.1/ooffice-wrapper-1.3 b/app-office/openoffice/files/1.1.1/ooffice-wrapper-1.3
new file mode 100644
index 000000000000..3cc043f2ceed
--- /dev/null
+++ b/app-office/openoffice/files/1.1.1/ooffice-wrapper-1.3
@@ -0,0 +1,280 @@
+#!/bin/sh
+#
+# Wrapper script for openoffice
+#
+# (C) Peter 'Nidd' Novodvorsky, 2001,2002
+# (C) Martin 'empty' Quinson, 2002.
+# Modifications by Chris Halls
+# Modifications by Lucien Saviot
+
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
+# this string should be exactly as in ~/.sversionrc
+PV=<pv>
+OOVERSION="OpenOffice.org ${PV}"
+
+##
+## Source system configuration file
+##
+[ -r /etc/openoffice/openoffice.conf ] && . /etc/openoffice/openoffice.conf
+
+# Migration to new user install dir
+if [ -d "$HOME/.openoffice/1.1.0" ] ; then
+ mv $HOME/.openoffice/1.1.0 $HOME/.openoffice/1.1
+ sed -i -e s/'.openoffice\/1.1.0'/'.openoffice\/1.1'/g $HOME/.sversionrc
+ sed -i -e s/org1.1.0/org/g $HOME/.openoffice/1.1/user/basic/*.xlc
+ sed -i -e s/1.1.0/1.1/g $HOME/.openoffice/1.1/user/basic/*.xlc
+ echo "Your user install dir has been moved over to the new version"
+fi
+
+#Make smooth up- and downgrading between minor versions possible
+if [ -e "$HOME/.sversionrc" ] ; then
+ sed -i -e s/1.1.0/1.1.1/g $HOME/.sversionrc
+fi
+
+###
+### Get user settings directory from ~/.sversionrc and echo directory name to stdout
+### get_settings_dir <Version>
+### return: 0 - directory found,
+### 1 - ~/.sversionrc non existent
+### 2 - entry exists in ~/.sversionrc but directory not found
+### 3 - ~/.sversionrc exists but no entry found
+get_settings_dir()
+{
+ [ -r ${HOME}/.sversionrc ] || exit 1
+ # warning, .sversionrc is DOS encoded so strip ^M
+ settings_dir="`tr -d '\r' < ~/.sversionrc | sed -n "/^$1=/s%^$1=file://\(.*\)$%\1%p"`"
+ echo "$settings_dir"
+ [ -n "$settings_dir" ] || exit 3
+ [ -d "$settings_dir" ] || exit 2
+}
+
+##
+## where does OO live for this user ?
+##
+OOHOME="`get_settings_dir "$OOVERSION"`"
+if [ $? -eq 2 ] ; then
+ # .sversionrc contains a version yet the directory does not exist
+ echo "I'm confused because I can't find OpenOffice's user files."
+ echo "Your ~/.sversionrc file tells they should be under $OOHOME,"
+ echo "but they are not. Please fix the situation manually."
+ echo "You may want to edit ~/.sversionrc to indicate where is OO"
+ echo "installed, or remove it if you did remove your installation"
+ echo "directory manually (you bad one)."
+ exit 1
+fi
+
+##
+## Unset SESSION_MANAGER if gnome-session is the session manager
+## See http://www.openoffice.org/issues/show_bug.cgi?id=4494
+##
+SMPID=`echo $SESSION_MANAGER | sed --quiet "s,local.*/,,p"`
+if [ -n "$SMPID" ] && [ -L /proc/"$SMPID"/exe ]; then
+
+ SESMGR="`readlink -f /proc/$SMPID/exe`"
+ case "$SESMGR" in
+ /usr/bin/gnome-session*)
+ echo "Gnome session manager detected - session management disabled"
+ unset SESSION_MANAGER
+ ;;
+ esac
+fi
+
+##
+## Add known Debian fonts locations to search path
+##
+## Please report if you have problems with fonts, or know of non-defoma integrated packages that place fonts in other
+## paths.
+##
+
+# Default font path. This is used if SAL_FONTPATH_USER is not defined.
+DEBOO_FONTPATH="/usr/lib/X11/fonts/misc/;/usr/lib/X11/fonts/cyrillic/;\
+/usr/lib/X11/fonts/100dpi/:unscaled;/usr/lib/X11/fonts/75dpi/:unscaled;\
+/usr/lib/X11/fonts/Type1/;/usr/lib/X11/fonts/CID;/usr/lib/X11/fonts/Speedo/;\
+/usr/lib/X11/fonts/100dpi/;/usr/lib/X11/fonts/75dpi/;\
+/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType;\
+/usr/lib/X11/fonts/TrueType;\
+/usr/share/fonts/truetype/kochi;\
+/usr/lib/X11/fonts/TrueType/larabie-straight;\
+/usr/lib/X11/fonts/TrueType/larabie-uncommon"
+
+SAL_FONTPATH_USER=${SAL_FONTPATH_USER:-"$DEBOO_FONTPATH"}
+export SAL_FONTPATH_USER
+
+## search LOCALE
+if [ -n "$LC_ALL" ]; then
+ LOCALE="$LC_ALL"
+ # OOo doesn't understand LC_ALL, so set LANG
+ LANG="$LC_ALL"
+elif [ -n "$LANG" ]; then
+ LOCALE="$LANG"
+elif [ -n "$LC_MESSAGES" ]; then
+ LOCALE="$LC_MESSAGES"
+ LANG="$LC_MESSAGES"
+else
+ LOCALE="en_US"
+fi
+
+# Set locale to en_US if locale is C
+if [ "x$LOCALE" = "xC" ] ; then LOCALE="en_US"; fi
+
+LOCALEOO=`echo $LOCALE | sed 's/_/-/'`
+
+##
+## install OO for this user if needed
+##
+if [ -z "$OOHOME" ] ; then
+ if [ -e /etc/openoffice/autoresponse-<pv>.conf ] && \
+ grep -q DESTINATIONPATH /etc/openoffice/autoresponse-<pv>.conf ; then
+
+# Do not take old settings as migration results in broken behaviour
+#
+# UPDATEFLAG=""
+# if oldhome="`get_settings_dir "OpenOffice.org 1.0.3"`" ; then
+# OOHOME="$oldhome"
+# echo "Using settings from 1.0.3: /${oldhome}"
+# /bin/echo -e "OpenOffice.org <pv>=file://$oldhome\r" >> ~/.sversionrc
+# UPDATEFLAG="-update:/$oldhome"
+# fi
+ # first install
+ OOHOME=`grep DESTINATIONPATH /etc/openoffice/autoresponse-<pv>.conf | \
+ sed -e 's/DESTINATIONPATH=//' -e "s|<home>|$HOME|"`
+
+ if [ -d "$OOHOME" ]; then
+ echo "openoffice.org: You have no entry for $OOVERSION in ~/.sversionrc, "
+ echo "yet the directory $OOHOME exists."
+ echo "Please remove $OOHOME and try again."
+ exit 1
+ fi
+
+ echo "running openoffice.org setup..."
+ if ! /opt/OpenOffice.org/program/setup ${UPDATEFLAG} -R:/etc/openoffice/autoresponse-<pv>.conf >& /dev/null; then
+ echo "setup failed.. abort"
+ exit 1
+ fi
+
+
+# fi
+
+ echo "Setup complete. Running openoffice.org..."
+
+else
+ echo "openoffice.org: Damnit! I can't find OpenOffice's user files. Did you break"
+ echo "the /etc/openoffice/autoresponse-<pv>.conf file manually ?"
+ echo "This file should contain DESTINATIONPATH"
+ exit 1
+ fi
+fi
+
+##
+## If no file is specified on the command line, which application to start?
+## The wrapper can be called from several links in /usr/bin
+##
+if [ $# = 0 ]; then
+ case `basename $0` in
+ oocalc) set -- private:factory/scalc;;
+ oodraw) set -- private:factory/sdraw;;
+ ooimpress) set -- private:factory/simpress;;
+ oomath) set -- private:factory/smath;;
+ oowriter) set -- private:factory/swriter;;
+ oohtml) set -- private:factory/swriter/web;;
+ oomaster) set -- private:factory/swriter/Global;;
+ esac
+fi
+
+## Previous dead installation?
+[ -d $HOME/.openoffice/user ] && echo "Warning: you have a user settings directory from 1.0.0 in ~/.openoffice/user - this is no longer used"
+
+# There is no locale import file
+## Change the ooLocale key in SETUPFILE acording to LOCALE
+#TMPFILE=`mktemp -t oooLocale.XXXXXXXXXX` && {
+# cat >${TMPFILE} <<EOF
+#<?xml version="1.0" encoding="UTF-8"?>
+#<oor:node xmlns:oor="http://openoffice.org/2001/registry" xmlns:xs="http://www.w3.org/2001/XMLSchema" oor:name="Setup" oor:package="org.openoffice">
+# <node oor:name="L10N">
+# <prop oor:name="ooLocale" oor:type="xs:string">
+# <value>$LOCALEOO</value>
+# </prop>
+# </node>
+#</oor:node>
+#EOF
+# ooconfigimport $TMPFILE >/dev/null
+# rm -f ${TMPFILE}
+#}
+
+# Check whether the programs actually link to anything, or are from an old
+# version.
+
+if [ ! -s $OOHOME/setup ]; then
+ echo "${OOHOME}/setup links to nothing, resetting link"
+ ln -sf /opt/OpenOffice.org/program/setup ${OOHOME}/setup
+fi
+if [ ! -s $OOHOME/soffice ]; then
+ echo "${OOHOME}/soffice links to nothing, resetting link"
+ ln -sf /opt/OpenOffice.org/program/soffice ${OOHOME}/soffice
+fi
+if [ ! -s $OOHOME/spadmin ]; then
+ echo "${OOHOME}/spadmin links to nothing, resetting link"
+ ln -sf /opt/OpenOffice.org/program/soffice ${OOHOME}/spadmin
+fi
+
+
+##
+## That's it. Launch the beast (with the given args)
+##
+LANG=$LOCALE
+export LANG
+case `basename $0` in
+ oosetup) exec "$OOHOME/setup"
+ ;;
+ oopadmin) exec "$OOHOME/spadmin"
+ ;;
+ *) exec "$OOHOME/soffice" "$@"
+ ;;
+esac
+## Changelog
+# 2003/04/01 halls
+# * Version 1.1beta
+# 2003/02/03 halls
+# * Check for nonexistent ooLocale every run
+# 2003/01/09 halls
+# * Version 1.0.2
+# 12/15 saviot
+# * Change ooLocale at startup in Setup.xml
+# <ooLocale cfg:type="string"/> doesn't work for help.
+# 12/03 challs
+# * Add Debian font paths to user font path
+# 11/14 saviot
+# * correct handling of UI language
+# * don't change Linguistic.xml after first startup(#168780)
+# * TODO: provide better defaults on first startup
+# 10/03 challs
+# * Fix use with LC_ALL
+# 07/10 challs
+# * use 1.0.1 directory and improve error checking
+# 07/02 challs
+# * use readlink in /proc/PID/exe to get
+# real session manager name
+# 06/12 challs
+# * merge into main package
+# * change $@ to "$@"
+# * source configuration file:
+# /etc/openoffice/openoffice.conf
+# 06/12 mquinson
+# * strace only when DEBUG is set to yes
+# * readd the $@ to pass the args to soffice
+# 06/06 mquinson
+# * Make sure the OLDLOCALE is never empty
+# * handle the case where the locale is C
diff --git a/app-office/openoffice/files/1.1.1/openoffice-java.patch b/app-office/openoffice/files/1.1.1/openoffice-java.patch
new file mode 100644
index 000000000000..46a6e9734aa6
--- /dev/null
+++ b/app-office/openoffice/files/1.1.1/openoffice-java.patch
@@ -0,0 +1,36 @@
+diff -urN oo_1.1_src.orig/odk/source/OOSupport/org/netbeans/modules/openoffice/wizard/OOAddInCreateIterator.java oo_1.1_src/odk/source/OOSupport/org/netbeans/modules/openoffice/wizard/OOAddInCreateIterator.java
+--- oo_1.1_src.orig/odk/source/OOSupport/org/netbeans/modules/openoffice/wizard/OOAddInCreateIterator.java 2004-02-10 01:00:11.000000000 +0100
++++ oo_1.1_src/odk/source/OOSupport/org/netbeans/modules/openoffice/wizard/OOAddInCreateIterator.java 2004-02-09 11:19:53.000000000 +0100
+@@ -200,7 +200,7 @@
+ index--;
+ }
+
+- public org.openide.WizardDescriptor$Panel current() {
++ public org.openide.WizardDescriptor.Panel current() {
+ return panels[index];
+ }
+
+diff -urN oo_1.1_src.orig/odk/source/OOSupport/org/netbeans/modules/openoffice/wizard/OOIDLWizardIterator.java oo_1.1_src/odk/source/OOSupport/org/netbeans/modules/openoffice/wizard/OOIDLWizardIterator.java
+--- oo_1.1_src.orig/odk/source/OOSupport/org/netbeans/modules/openoffice/wizard/OOIDLWizardIterator.java 2004-02-10 01:00:48.000000000 +0100
++++ oo_1.1_src/odk/source/OOSupport/org/netbeans/modules/openoffice/wizard/OOIDLWizardIterator.java 2004-02-09 11:20:15.000000000 +0100
+@@ -207,7 +207,7 @@
+ index--;
+ }
+
+- public org.openide.WizardDescriptor$Panel current()
++ public org.openide.WizardDescriptor.Panel current()
+ {
+ return panels[index];
+ }
+diff -urN oo_1.1_src.orig/odk/source/OOSupport/org/netbeans/modules/openoffice/wizard/OOServiceCreateIterator.java oo_1.1_src/odk/source/OOSupport/org/netbeans/modules/openoffice/wizard/OOServiceCreateIterator.java
+--- oo_1.1_src.orig/odk/source/OOSupport/org/netbeans/modules/openoffice/wizard/OOServiceCreateIterator.java 2004-02-10 01:01:29.000000000 +0100
++++ oo_1.1_src/odk/source/OOSupport/org/netbeans/modules/openoffice/wizard/OOServiceCreateIterator.java 2004-02-09 11:20:35.000000000 +0100
+@@ -214,7 +214,7 @@
+ index--;
+ }
+
+- public org.openide.WizardDescriptor$Panel current() {
++ public org.openide.WizardDescriptor.Panel current() {
+ return panels[index];
+ }
+
diff --git a/app-office/openoffice/files/digest-openoffice-1.1.1 b/app-office/openoffice/files/digest-openoffice-1.1.1
new file mode 100644
index 000000000000..08166460ab51
--- /dev/null
+++ b/app-office/openoffice/files/digest-openoffice-1.1.1
@@ -0,0 +1,2 @@
+MD5 1919ec0ef5d3e8fe4b0a4910856d8987 OOo_1.1.1_source.tar.bz2 192665594
+MD5 fdb06fdb5a4670b172f9fb738b717be9 gpc231.tar.Z 27917