summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/kplato/kplato-2.3.1.ebuild')
-rw-r--r--app-office/kplato/kplato-2.3.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-office/kplato/kplato-2.3.1.ebuild b/app-office/kplato/kplato-2.3.1.ebuild
new file mode 100644
index 000000000000..bf00fe436164
--- /dev/null
+++ b/app-office/kplato/kplato-2.3.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kplato/kplato-2.3.1.ebuild,v 1.1 2011/01/20 00:09:10 dilfridge Exp $
+
+EAPI=3
+
+KMNAME="koffice"
+KMMODULE="${PN}"
+inherit kde4-meta
+
+DESCRIPTION="KOffice project management application"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="~app-office/koffice-libs-${PV}:${SLOT}[reports]"
+RDEPEND="${DEPEND}"
+
+KMEXTRACTONLY="
+ KoConfig.h.cmake
+ libs/
+ plugins/chartshape/kdchart
+"
+KMEXTRA="
+ filters/${KMMODULE}/
+ kdgantt/
+"
+KMLOADLIBS="koffice-libs"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with python PythonLibs)
+ -DBUILD_kplato=ON
+ )
+
+ kde4-meta_src_configure
+}
+
+src_install() {
+ kde4-meta_src_install
+
+ # this is already installed by koffice-data
+ rm -f "${D}/usr/include/config-opengl.h"
+ rm -f "${D}/usr/include/KoConfig.h"
+}