summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/kanatest/kanatest-0.4.8.ebuild')
-rw-r--r--app-misc/kanatest/kanatest-0.4.8.ebuild17
1 files changed, 11 insertions, 6 deletions
diff --git a/app-misc/kanatest/kanatest-0.4.8.ebuild b/app-misc/kanatest/kanatest-0.4.8.ebuild
index b707523feb0e..eec8e186e43b 100644
--- a/app-misc/kanatest/kanatest-0.4.8.ebuild
+++ b/app-misc/kanatest/kanatest-0.4.8.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/kanatest/kanatest-0.4.8.ebuild,v 1.5 2010/03/23 20:39:34 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/kanatest/kanatest-0.4.8.ebuild,v 1.6 2010/10/17 01:33:33 flameeyes Exp $
-inherit eutils
+inherit eutils autotools
DESCRIPTION="Visual flashcard tool for memorizing the Japanese Hiragana and Katakana alphabet"
HOMEPAGE="http://www.clayo.org/kanatest"
@@ -18,11 +18,16 @@ RDEPEND=">=x11-libs/gtk+-2.12
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}+gtk-2.22.patch
+ eautoreconf
+}
+
src_install() {
emake DESTDIR="${D}" install || die
- doicon kanatest.svg
- make_desktop_entry "${PN}" Kanatest "${PN}" "GNOME;Education;X-KDE-Edu-Language;"
-
- dodoc AUTHORS ChangeLog README
+ dodoc AUTHORS TRANSLATORS ChangeLog README || die
}