summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/ibus-skk/ibus-skk-1.3.9.ebuild')
-rw-r--r--app-i18n/ibus-skk/ibus-skk-1.3.9.ebuild16
1 files changed, 6 insertions, 10 deletions
diff --git a/app-i18n/ibus-skk/ibus-skk-1.3.9.ebuild b/app-i18n/ibus-skk/ibus-skk-1.3.9.ebuild
index 5bf3693a8c36..90569828989e 100644
--- a/app-i18n/ibus-skk/ibus-skk-1.3.9.ebuild
+++ b/app-i18n/ibus-skk/ibus-skk-1.3.9.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-skk/ibus-skk-1.3.9.ebuild,v 1.2 2012/03/08 09:03:38 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-skk/ibus-skk-1.3.9.ebuild,v 1.3 2012/03/09 19:56:02 ssuominen Exp $
-EAPI="3"
+EAPI=4
PYTHON_DEPEND="2:2.5"
+
inherit python
DESCRIPTION="Japanese input method Anthy IMEngine for IBus Framework"
@@ -22,26 +23,21 @@ DEPEND="${RDEPEND}
RDEPEND="${RDEPEND}
app-i18n/skk-jisyo"
+DOCS="ChangeLog NEWS README THANKS TODO"
+
pkg_setup() {
python_set_active_version 2
python_pkg_setup
}
src_prepare() {
- mv py-compile py-compile.orig || die
- ln -s "$(type -P true)" py-compile || die
+ >py-compile
}
src_configure() {
econf $(use_enable nls)
}
-src_install() {
- emake DESTDIR="${D}" install || die
-
- dodoc AUTHORS ChangeLog NEWS README THANKS TODO || die
-}
-
pkg_postinst() {
python_mod_optimize /usr/share/${PN}
}