summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/navi2ch/navi2ch-1.8.2.ebuild')
-rw-r--r--app-emacs/navi2ch/navi2ch-1.8.2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-emacs/navi2ch/navi2ch-1.8.2.ebuild b/app-emacs/navi2ch/navi2ch-1.8.2.ebuild
new file mode 100644
index 000000000000..a994454192e6
--- /dev/null
+++ b/app-emacs/navi2ch/navi2ch-1.8.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/navi2ch/navi2ch-1.8.2.ebuild,v 1.1 2009/03/01 23:52:46 matsuu Exp $
+
+inherit elisp
+
+DESCRIPTION="A navigator for 2ch"
+HOMEPAGE="http://navi2ch.sourceforge.net/"
+SRC_URI="mirror://sourceforge/navi2ch/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+SITEFILE=50${PN}-gentoo.el
+
+src_compile() {
+ econf \
+ --with-lispdir=${SITELISP}/${PN} \
+ --with-icondir=${SITEETC}/${PN} \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ elisp-install ${PN} contrib/*.el || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
+ || die "elisp-site-file-install failed"
+ dodoc ChangeLog* NEWS README TODO
+ newdoc contrib/README README.contrib
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ elog
+ elog "Please add to your ~/.emacs"
+ elog "If you use mona-font,"
+ elog "\t(setq navi2ch-mona-enable t)"
+ elog "If you use izonmoji-mode,"
+ elog "\t(require 'izonmoji-mode)"
+ elog "\t(add-hook 'navi2ch-bm-mode-hook 'izonmoji-mode-on)"
+ elog "\t(add-hook 'navi2ch-article-mode-hook 'izonmoji-mode-on)"
+ elog "\t(add-hook 'navi2ch-popup-article-mode-hook 'izonmoji-mode-on)"
+ elog
+}