summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/vim/vim-7.0.243.ebuild')
-rw-r--r--app-editors/vim/vim-7.0.243.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-editors/vim/vim-7.0.243.ebuild b/app-editors/vim/vim-7.0.243.ebuild
new file mode 100644
index 000000000000..8d3d247eb079
--- /dev/null
+++ b/app-editors/vim/vim-7.0.243.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-7.0.243.ebuild,v 1.1 2009/02/20 15:48:40 lack Exp $
+
+inherit vim
+
+VIM_VERSION="7.0"
+VIM_SNAPSHOT="vim-7.0-r1.tar.bz2"
+VIM_GENTOO_PATCHES="vim-7.0-gentoo-patches-r1.tar.bz2"
+VIM_ORG_PATCHES="vim-patches-${PV}.tar"
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/${VIM_SNAPSHOT}
+ mirror://gentoo/${VIM_GENTOO_PATCHES}
+ mirror://gentoo/${VIM_ORG_PATCHES}"
+
+S=${WORKDIR}/vim${VIM_VERSION/.*}
+DESCRIPTION="Vim, an improved vi-style text editor"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+DEPEND="${DEPEND}
+ !minimal? ( ~app-editors/vim-core-${PV} )"
+RDEPEND="${RDEPEND}
+ !<app-editors/nvi-1.81.5-r4
+ !minimal? ( ~app-editors/vim-core-${PV} )"