summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/gpgme/gpgme-0.3.9.ebuild')
-rw-r--r--app-crypt/gpgme/gpgme-0.3.9.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-crypt/gpgme/gpgme-0.3.9.ebuild b/app-crypt/gpgme/gpgme-0.3.9.ebuild
new file mode 100644
index 000000000000..4fc70c12dbe2
--- /dev/null
+++ b/app-crypt/gpgme/gpgme-0.3.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpgme/gpgme-0.3.9.ebuild,v 1.1 2002/08/24 00:25:05 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier for applications."
+SRC_URI="ftp://ftp.gnupg.org/gcrypt/alpha/gpgme/${P}.tar.gz"
+HOMEPAGE="http://www.gnupg.org/gpgme.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc sparc64"
+
+DEPEND=">=sys-libs/zlib-1.1.3
+ >=app-crypt/gnupg-1.0.6"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+ use nls || myconf="--disable-nls"
+
+ econf \
+ --enable-gpgmeplug \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README README-alpha THANKS TODO
+}