summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/deb2targz/deb2targz-1-r1.ebuild')
-rw-r--r--app-arch/deb2targz/deb2targz-1-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-arch/deb2targz/deb2targz-1-r1.ebuild b/app-arch/deb2targz/deb2targz-1-r1.ebuild
new file mode 100644
index 000000000000..6155b1c3a48d
--- /dev/null
+++ b/app-arch/deb2targz/deb2targz-1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/deb2targz/deb2targz-1-r1.ebuild,v 1.1 2011/08/30 10:50:04 chainsaw Exp $
+
+EAPI=4
+inherit base
+
+DESCRIPTION="Convert a .deb file to a .tar.gz archive"
+HOMEPAGE="http://www.miketaylor.org.uk/tech/deb/"
+SRC_URI="http://www.miketaylor.org.uk/tech/deb/${PN}"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/perl"
+
+S=${WORKDIR}
+PATCHES=( "${FILESDIR}/${PN}-lzma-support.patch" )
+
+src_unpack() {
+ cp "${DISTDIR}/${PN}" "${S}"
+}
+
+src_install() {
+ dobin ${PN}
+}