summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility/speech-dispatcher/speech-dispatcher-0.6.ebuild')
-rw-r--r--app-accessibility/speech-dispatcher/speech-dispatcher-0.6.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.ebuild b/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.ebuild
new file mode 100644
index 000000000000..939b7036536c
--- /dev/null
+++ b/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.ebuild,v 1.1 2006/01/28 23:46:56 williamh Exp $
+
+DESCRIPTION="speech-dispatcher speech synthesis interface"
+HOMEPAGE="http://www.freebsoft.org/speechd"
+SRC_URI="http://www.freebsoft.org/pub/projects/speechd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+
+DEPEND="dev-libs/dotconf
+ >=app-accessibility/flite-1.2
+ >=dev-libs/glib-2
+ media-libs/alsa-lib"
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/speech-dispatcher
+
+ insinto /usr/include
+ doins ${S}/src/c/api/libspeechd.h
+}
+
+pkg_postinst() {
+ echo
+ einfo "To enable Festival support, you must install app-accessibility/festival-freebsoft-utils."
+ echo
+}