summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility/espeak/espeak-1.30.ebuild')
-rw-r--r--app-accessibility/espeak/espeak-1.30.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/app-accessibility/espeak/espeak-1.30.ebuild b/app-accessibility/espeak/espeak-1.30.ebuild
new file mode 100644
index 000000000000..b114cf2cceaf
--- /dev/null
+++ b/app-accessibility/espeak/espeak-1.30.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/espeak-1.30.ebuild,v 1.1 2008/01/01 04:37:50 williamh Exp $
+
+inherit eutils
+
+MY_P="${P}-source"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
+DESCRIPTION="Speech synthesizer for English and other languages"
+HOMEPAGE="http://espeak.sourceforge.net/"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+DEPEND=">=media-libs/portaudio-18.1-r5
+ app-arch/unzip"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # portaudio.h is by default the same as portaudio18.h, but use the version
+ # 19 API if available
+ if has_version "=media-libs/portaudio-19*" ; then
+ mv -f "${S}/src/portaudio19.h" "${S}/src/portaudio.h"
+ fi
+
+ # Add a patch for a segfault on ppc64.
+# epatch "${FILESDIR}/${P}-ppc64-segfault.patch"
+}
+
+src_compile() {
+ cd src
+ emake CXXFLAGS="${CXXFLAGS}" || die "Compilation failed"
+
+ einfo "Fixing byte order of phoneme data files"
+ cd "${S}/platforms/big_endian"
+ make
+ ./espeak-phoneme-data "${S}/espeak-data"
+ cp -f phondata phonindex phontab "${S}/espeak-data"
+
+ einfo "Compiling dict files"
+ cd "${S}/dictsource"
+ export HOME="${S}"
+ local lang
+ for l in *_rules; do
+ lang=${l/_rules/}
+ "${S}/src/speak" --compile=$lang
+ done
+}
+
+src_install() {
+ cd src
+ make DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)" install || die "Installation failed"
+
+ cd ..
+ dodoc ChangeLog ReadMe
+ dohtml -r docs/*
+}