summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-strategy/wesnoth/ChangeLog7
-rw-r--r--games-strategy/wesnoth/Manifest4
-rw-r--r--games-strategy/wesnoth/wesnoth-1.6a.ebuild92
3 files changed, 101 insertions, 2 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index e68039f01055..c257d0dce0b2 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.139 2009/03/11 15:13:59 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.140 2009/03/23 02:14:13 mr_bones_ Exp $
+
+*wesnoth-1.6a (23 Mar 2009)
+
+ 23 Mar 2009; Michael Sterrett <mr_bones_@gentoo.org> +wesnoth-1.6a.ebuild:
+ version bump
11 Mar 2009; Brent Baude <ranger@gentoo.org> wesnoth-1.4.7-r1.ebuild:
Marking wesnoth-1.4.7-r1 ppc and ppc64 for bug 255394
diff --git a/games-strategy/wesnoth/Manifest b/games-strategy/wesnoth/Manifest
index cb4539a1845b..a6bcd247b191 100644
--- a/games-strategy/wesnoth/Manifest
+++ b/games-strategy/wesnoth/Manifest
@@ -1,6 +1,8 @@
AUX no-python.patch 770 RMD160 9fe2785748a54c54a05699ce6686bf3b9c25ab39 SHA1 dd025bf9a0c85c78dd128aa3b18dcdce34a93d4b SHA256 4e5254615565151cdd15a93c0a4aaa79a708cdf2d47eb39057f22f877db9e8ff
AUX wesnothd.rc 619 RMD160 b3d7a303f27ce3cc1886fd7791ab58f58356ac39 SHA1 8ba6dad055ea943485c0a1cf324e39a340c89b00 SHA256 23e250272768e1fb540104b96c96a24da09fedc9f89a6867adcae046160c0065
DIST wesnoth-1.4.7.tar.bz2 155052245 RMD160 8a515aca790424a550505512eb42b101860e87b2 SHA1 f8eb17e7a7aaff5d8fff1e18a1479efcf932fd27 SHA256 63c85889ef8c08e6dd5ea977edd057d64ce65a4934e661e222d2b0dd89e26847
+DIST wesnoth-1.6a.tar.bz2 225396333 RMD160 0cee144eb1454202245bd4db07ccc8011170d8d2 SHA1 9baef5dbba36c77b86382f1a1d8bb3826ef18cc8 SHA256 fed9c9da6d7780dc503958a48e6c356f9ced4a8a3e1530ccf9610238b532ae19
EBUILD wesnoth-1.4.7-r1.ebuild 3233 RMD160 6b5166ea6e91d77f3f1a605808b8092631d85784 SHA1 661737fe591cf566b1b3249c6062e7445b919169 SHA256 b666aed774d4c980808739a8feb92940b13aedc56c450dca7d0df983866d052e
-MISC ChangeLog 18334 RMD160 d939b81041421c49c23ecc6883ef262b9483523f SHA1 bfb647f4090155b763af390ab4d1377ba8608cc8 SHA256 f631177558c3075edb495dd7853c8d1aa562988250752cd6531d88c551b753ef
+EBUILD wesnoth-1.6a.ebuild 2532 RMD160 b80fd12236c3ccd987ef8f48b3eaf08a980a8fd1 SHA1 0cafc757e2bf18ea355c4d7055799d027b438a5a SHA256 d209972feb83b9966c2828b56577f000388de404dbd82e183bc56f7898baeba2
+MISC ChangeLog 18459 RMD160 4cd706f1fc289e28a930e5afce0c1273cd5f7ccb SHA1 c5841e5f226e0a41de37e3bd210b5084621c35fb SHA256 88bb2bc4755e07264851f5d27e97df5f381bffe61f37ceee809f1170220af96a
MISC metadata.xml 612 RMD160 f14f4748e1c611b41864ee5e1bdaa9e56de55d4a SHA1 f77e1b84262e73a7ab77b13666e6e00a0cbe593c SHA256 0c38c6a5c0cd5fee19c6c57c52f50c4e383581af23098aabbe4bbf43c9f5f2f7
diff --git a/games-strategy/wesnoth/wesnoth-1.6a.ebuild b/games-strategy/wesnoth/wesnoth-1.6a.ebuild
new file mode 100644
index 000000000000..61dccd12a700
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-1.6a.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.6a.ebuild,v 1.1 2009/03/23 02:14:13 mr_bones_ Exp $
+
+EAPI=2
+inherit cmake-utils eutils toolchain-funcs flag-o-matic games
+
+DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="mirror://sourceforge/wesnoth/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="dedicated nls server tinygui"
+
+RDEPEND=">=media-libs/libsdl-1.2.7[X]
+ media-libs/sdl-net
+ >=media-libs/sdl-ttf-2.0.8
+ >=media-libs/sdl-mixer-1.2[vorbis]
+ >=media-libs/sdl-image-1.2[jpeg,png]
+ dev-libs/boost
+ sys-libs/zlib
+ x11-libs/pango
+ media-libs/fontconfig
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ !dedicated? (
+ tinygui? ( media-gfx/imagemagick[jpeg,png] )
+ )
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_prepare() {
+ if use dedicated || use server ; then
+ sed \
+ -e "s:GAMES_BINDIR:${GAMES_BINDIR}:" \
+ -e "s:GAMES_STATEDIR:${GAMES_STATEDIR}:" \
+ -e "s/GAMES_USER_DED/${GAMES_USER_DED}/" \
+ -e "s/GAMES_GROUP/${GAMES_GROUP}/" "${FILESDIR}"/wesnothd.rc \
+ > "${T}"/wesnothd \
+ || die "sed failed"
+ fi
+}
+
+src_configure() {
+ filter-flags -ftracer -fomit-frame-pointer
+ if [[ $(gcc-major-version) -eq 3 ]] ; then
+ filter-flags -fstack-protector
+ append-flags -fno-stack-protector
+ fi
+ if use dedicated || use server ; then
+ mycmakeargs="${mycmakeargs}
+ -DENABLE_CAMPAIGN_SERVER=TRUE
+ -DENABLE_SERVER=TRUE
+ -DSERVER_UID=${GAMES_USER_DED}
+ -DSERVER_GID=${GAMES_GROUP}
+ -DFIFO_DIR=${GAMES_STATEDIR}/run/wesnothd"
+ else
+ mycmakeargs="${mycmakeargs}
+ -DENABLE_CAMPAIGN_SERVER=FALSE
+ -DENABLE_SERVER=FALSE"
+ fi
+ mycmakeargs="
+ ${mycmakeargs}
+ -DENABLE_GAME=$(use dedicated && echo FALSE || echo TRUE)
+ -DENABLE_NLS=$(use nls && echo TRUE || echo FALSE)
+ -DGUI=$(use tinygui && echo tiny || echo normal)
+ -DENABLE_FRIBIDI=FALSE
+ -DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}
+ -DPREFERENCES_DIR=.wesnoth
+ -DDATAROOTDIR=${GAMES_DATADIR}
+ -DBINDIR=${GAMES_BINDIR}
+ -DMANDIR=/usr/share/man
+ -DDOCDIR=/usr/share/doc/${PF}"
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ DOCS="README changelog players_changelog" cmake-utils_src_install
+ if use dedicated || use server; then
+ keepdir "${GAMES_STATEDIR}/run/wesnothd"
+ doinitd "${T}"/wesnothd || die "doinitd failed"
+ fi
+ prepgamesdirs
+}