summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/check/check-0.8.4.ebuild12
-rw-r--r--dev-libs/physfs/physfs-0.1.7.ebuild7
-rw-r--r--dev-libs/slib/slib-2.4.2.ebuild19
-rw-r--r--dev-libs/slib/slib-2.4.3.ebuild19
-rw-r--r--dev-libs/vrb/vrb-0.3.0.ebuild15
5 files changed, 27 insertions, 45 deletions
diff --git a/dev-libs/check/check-0.8.4.ebuild b/dev-libs/check/check-0.8.4.ebuild
index 27265b6d3a89..28a39d3580c1 100644
--- a/dev-libs/check/check-0.8.4.ebuild
+++ b/dev-libs/check/check-0.8.4.ebuild
@@ -1,19 +1,19 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/check/check-0.8.4.ebuild,v 1.2 2003/02/13 10:34:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/check/check-0.8.4.ebuild,v 1.3 2003/03/01 04:55:45 vapier Exp $
-DESCRIPTION="Check is a unit test framework for C."
+DESCRIPTION="unit test framework for C"
HOMEPAGE="http://sourceforge.net/projects/check/"
-SRC_URI="http://unc.dl.sourceforge.net/sourceforge/${PN}/${P}.tar.gz"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc"
-IUSE=""
+
DEPEND="virtual/glibc"
-S=${WORKDIR}/${P}
src_compile() {
- econf
+ econf || die
emake || die
}
diff --git a/dev-libs/physfs/physfs-0.1.7.ebuild b/dev-libs/physfs/physfs-0.1.7.ebuild
index 915068169db9..974fdd69779b 100644
--- a/dev-libs/physfs/physfs-0.1.7.ebuild
+++ b/dev-libs/physfs/physfs-0.1.7.ebuild
@@ -1,13 +1,10 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-DESCRIPTION="PhysicsFS is an abstraction layer for filesystems, useful for games."
+DESCRIPTION="abstraction layer for filesystems, useful for games"
SRC_URI="http://icculus.org/physfs/downloads/${P}.tar.gz"
HOMEPAGE="http://icculus.org/physfs/"
-S=${WORKDIR}/${P}
-IUSE=""
-
SLOT="0"
LICENSE="LGPL-2.1"
KEYWORDS="~x86"
@@ -16,12 +13,10 @@ DEPEND="virtual/glibc"
src_compile() {
econf || die "./configure failed"
-
emake || die "Compilation failed"
}
src_install() {
einstall || die "Installation failed"
-
dodoc AUTHORS ChangeLog COPYING README TODO
}
diff --git a/dev-libs/slib/slib-2.4.2.ebuild b/dev-libs/slib/slib-2.4.2.ebuild
index 971a02e564ee..dca62ab65b82 100644
--- a/dev-libs/slib/slib-2.4.2.ebuild
+++ b/dev-libs/slib/slib-2.4.2.ebuild
@@ -1,37 +1,32 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/slib/slib-2.4.2.ebuild,v 1.9 2003/02/13 10:51:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/slib/slib-2.4.2.ebuild,v 1.10 2003/03/01 04:57:33 vapier Exp $
MY_P=${PN}2d2
S=${WORKDIR}/${PN}
-DESCRIPTION="SLIB is a library providing functions for Scheme implementations."
+DESCRIPTION="library providing functions for Scheme implementations"
SRC_URI="http://swissnet.ai.mit.edu/ftpdir/scm/${MY_P}.zip"
HOMEPAGE="http://swissnet.ai.mit.edu/~jaffer/SLIB.html"
SLOT="0"
LICENSE="public-domain BSD"
-KEYWORDS="x86 sparc "
+KEYWORDS="x86 sparc"
RDEPEND=">=dev-util/guile-1.4"
-
DEPEND="${RDEPEND}
>=app-arch/unzip-5.21
>=dev-util/guile-1.4"
-
-src_install () {
-
+src_install() {
insinto /usr/share/guile/site/slib
doins *.scm
dodoc ANNOUNCE ChangeLog FAQ README
doinfo slib.info
}
-pkg_postinst () {
-
- if [ "${ROOT}" == "/" ]
- then
- echo "Installing..."
+pkg_postinst() {
+ if [ "${ROOT}" == "/" ] ; then
+ einfo "Installing..."
guile -c "(use-modules (ice-9 slib)) (require 'new-catalog)" "/"
fi
}
diff --git a/dev-libs/slib/slib-2.4.3.ebuild b/dev-libs/slib/slib-2.4.3.ebuild
index 2c7b13e0018f..1845f3da1b51 100644
--- a/dev-libs/slib/slib-2.4.3.ebuild
+++ b/dev-libs/slib/slib-2.4.3.ebuild
@@ -1,37 +1,32 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/slib/slib-2.4.3.ebuild,v 1.9 2003/02/13 10:51:29 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/slib/slib-2.4.3.ebuild,v 1.10 2003/03/01 04:57:33 vapier Exp $
MY_P=${PN}2d3
S=${WORKDIR}/${PN}
-DESCRIPTION="SLIB is a library providing functions for Scheme implementations."
+DESCRIPTION="library providing functions for Scheme implementations"
SRC_URI="http://swissnet.ai.mit.edu/ftpdir/scm/${MY_P}.zip"
HOMEPAGE="http://swissnet.ai.mit.edu/~jaffer/SLIB.html"
SLOT="0"
LICENSE="public-domain BSD"
-KEYWORDS="x86 ppc sparc "
+KEYWORDS="x86 ppc sparc"
RDEPEND=">=dev-util/guile-1.4"
-
DEPEND="${RDEPEND}
>=app-arch/unzip-5.21
>=dev-util/guile-1.4"
-
-src_install () {
-
+src_install() {
insinto /usr/share/guile/site/slib
doins *.scm
dodoc ANNOUNCE ChangeLog FAQ README
doinfo slib.info
}
-pkg_postinst () {
-
- if [ "${ROOT}" == "/" ]
- then
- echo "Installing..."
+pkg_postinst() {
+ if [ "${ROOT}" == "/" ] ; then
+ einfo "Installing..."
guile -c "(use-modules (ice-9 slib)) (require 'new-catalog)" "/"
fi
}
diff --git a/dev-libs/vrb/vrb-0.3.0.ebuild b/dev-libs/vrb/vrb-0.3.0.ebuild
index 2f34914d5578..73d9649016e3 100644
--- a/dev-libs/vrb/vrb-0.3.0.ebuild
+++ b/dev-libs/vrb/vrb-0.3.0.ebuild
@@ -1,32 +1,29 @@
# Copyright 2002 Johannes Findeisen <you@hanez.org>
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/vrb/vrb-0.3.0.ebuild,v 1.5 2002/12/09 04:21:04 manson Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/vrb/vrb-0.3.0.ebuild,v 1.6 2003/03/01 04:58:43 vapier Exp $
-S="${WORKDIR}/${P}"
-DESCRIPTION="The VRB library is a virtual ring buffer"
+DESCRIPTION="library for a virtual ring buffer"
HOMEPAGE="http://phil.ipal.org/freeware/vrb/"
SRC_URI="http://phil.ipal.org/freeware/vrb/${P}.tar.gz"
SLOT="0"
LICENSE="LGPL-2.1"
-KEYWORDS="x86 sparc "
+KEYWORDS="x86 sparc"
DEPEND="virtual/glibc"
src_compile() {
-
sed -e "s/copts=\"-pipe -O2\"/copts=\"${CFLAGS}\"/g" \
< Configure > Configure.hacked
cp Configure.hacked Configure
-
+
./Configure \
--prefix=/usr || die "./Configure failed"
make || die "emake failed"
}
-src_install () {
-
+src_install() {
insinto /usr/include/libvrb/
doins include/vrb.h
@@ -37,5 +34,5 @@ src_install () {
dobin bin/iobuffer
- dodoc INSTALL LICENSE README
+ dodoc README
}