summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mail/cyrus-imap-admin/ChangeLog8
-rw-r--r--net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.14.ebuild72
-rw-r--r--net-mail/cyrus-imapd/ChangeLog8
-rw-r--r--net-mail/cyrus-imapd/cyrus-imapd-2.3.14.ebuild (renamed from net-mail/cyrus-imapd/cyrus-imapd-2.3.13-r1.ebuild)45
4 files changed, 95 insertions, 38 deletions
diff --git a/net-mail/cyrus-imap-admin/ChangeLog b/net-mail/cyrus-imap-admin/ChangeLog
index ad977ec92ccc..3137aa536a12 100644
--- a/net-mail/cyrus-imap-admin/ChangeLog
+++ b/net-mail/cyrus-imap-admin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/cyrus-imap-admin
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/ChangeLog,v 1.78 2009/02/16 18:56:05 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/ChangeLog,v 1.79 2009/04/11 16:10:30 dertobi123 Exp $
+
+*cyrus-imap-admin-2.3.14 (11 Apr 2009)
+
+ 11 Apr 2009; Tobias Scherbaum <dertobi123@gentoo.org>
+ +cyrus-imap-admin-2.3.14.ebuild:
+ Version bump
16 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
-cyrus-imap-admin-2.3.9.ebuild, -cyrus-imap-admin-2.3.11.ebuild,
diff --git a/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.14.ebuild b/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.14.ebuild
new file mode 100644
index 000000000000..49aba8a3d04f
--- /dev/null
+++ b/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.14.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.3.14.ebuild,v 1.1 2009/04/11 16:10:30 dertobi123 Exp $
+
+inherit autotools perl-app eutils
+
+MY_PV=${PV/_/}
+
+PIC_PATCH_VER="2.2"
+DESCRIPTION="Utilities and Perl modules to administer a Cyrus IMAP server."
+HOMEPAGE="http://asg.web.cmu.edu/cyrus/imapd/"
+SRC_URI="ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-imapd-${MY_PV}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ssl kerberos"
+
+RDEPEND=">=sys-libs/db-3.2
+ >=dev-lang/perl-5.6.1
+ >=dev-libs/cyrus-sasl-2.1.13
+ dev-perl/Term-ReadLine-Perl
+ dev-perl/TermReadKey
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ kerberos? ( virtual/krb5 )"
+
+DEPEND="$RDEPEND
+ sys-devel/libtool
+ >=sys-devel/autoconf-2.58
+ sys-devel/automake
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/cyrus-imapd-${MY_PV}"
+
+src_unpack() {
+ unpack ${A} && cd "${S}"
+
+ # Versioned symbols.
+ epatch "${FILESDIR}/${PN}-${PIC_PATCH_VER}-fPIC.patch"
+
+ # Recreate configure.
+ WANT_AUTOCONF="2.5"
+ eautoreconf
+
+ # When linking with rpm, you need to link with more libraries.
+ sed -e "s:lrpm:lrpm -lrpmio -lrpmdb:" -i configure || die "sed failed"
+}
+
+src_compile() {
+
+ local myconf
+ myconf="${myconf} `use_with ssl openssl`"
+ myconf="${myconf} `use_with kerberos krb`"
+
+ econf \
+ --disable-server \
+ --enable-murder \
+ --enable-listext \
+ --enable-netscapehack \
+ --with-cyrus-group=mail \
+ --with-com_err=yes \
+ --with-perl=/usr/bin/perl \
+ ${myconf} || die "econf failed"
+
+ emake -C "${S}/lib" all || die "compile problem"
+ emake -C "${S}/perl" all || die "compile problem"
+}
+
+src_install () {
+ make -C "${S}/perl" DESTDIR="${D}" install || die "install problem"
+ fixlocalpod # bug #98122
+}
diff --git a/net-mail/cyrus-imapd/ChangeLog b/net-mail/cyrus-imapd/ChangeLog
index 25c1d6d021ea..15aaa97840f5 100644
--- a/net-mail/cyrus-imapd/ChangeLog
+++ b/net-mail/cyrus-imapd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/cyrus-imapd
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imapd/ChangeLog,v 1.133 2009/02/16 19:04:37 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imapd/ChangeLog,v 1.134 2009/04/11 16:09:05 dertobi123 Exp $
+
+*cyrus-imapd-2.3.14 (11 Apr 2009)
+
+ 11 Apr 2009; Tobias Scherbaum <dertobi123@gentoo.org>
+ -cyrus-imapd-2.3.13-r1.ebuild, +cyrus-imapd-2.3.14.ebuild:
+ Version bump
16 Feb 2009; Tobias Scherbaum <dertobi123@gentoo.org>
-files/cyrus-imapd-2.3.8-drac_with_autocreate.patch,
diff --git a/net-mail/cyrus-imapd/cyrus-imapd-2.3.13-r1.ebuild b/net-mail/cyrus-imapd/cyrus-imapd-2.3.14.ebuild
index 391f3d4ef665..bef6c9c64465 100644
--- a/net-mail/cyrus-imapd/cyrus-imapd-2.3.13-r1.ebuild
+++ b/net-mail/cyrus-imapd/cyrus-imapd-2.3.14.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imapd/cyrus-imapd-2.3.13-r1.ebuild,v 1.1 2008/12/29 18:02:16 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imapd/cyrus-imapd-2.3.14.ebuild,v 1.1 2009/04/11 16:09:05 dertobi123 Exp $
EAPI=1
-inherit autotools eutils ssl-cert fixheadtails pam
+inherit autotools eutils ssl-cert fixheadtails pam multilib
MY_P=${P/_/}
@@ -16,7 +16,7 @@ LIBWRAP_PATCH_VER="2.2"
LICENSE="as-is"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-IUSE="drac idled kerberos kolab nntp pam replication +sieve snmp ssl tcpd"
+IUSE="idled kerberos nntp pam replication +sieve snmp ssl tcpd"
PROVIDE="virtual/imapd"
RDEPEND=">=sys-libs/db-3.2
@@ -29,9 +29,7 @@ RDEPEND=">=sys-libs/db-3.2
snmp? ( >=net-analyzer/net-snmp-5.2.2-r1 )
ssl? ( >=dev-libs/openssl-0.9.6 )
tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
- drac? ( >=mail-client/drac-1.12-r1 )
- nntp? ( !net-nntp/leafnode )
- kolab? ( net-nds/openldap )"
+ nntp? ( !net-nntp/leafnode )"
DEPEND="$RDEPEND
sys-devel/libtool
@@ -108,19 +106,6 @@ src_unpack() {
# Fix prestripped binaries
epatch "${FILESDIR}/${PN}-strip.patch"
- if use drac ; then
- epatch "${S}/contrib/drac_auth.patch"
- fi
-
- # KOLAB support
- if use kolab ; then
- EPATCH_SOURCE="${FILESDIR}/kolab/${PV}" EPATCH_SUFFIX="patch" \
- EPATCH_FORCE="yes" epatch
- # These files are being created automatically and need to be updated
- # # after the patches used above
- rm -f lib/imapopts.h lib/imapopts.c
- fi
-
# Add libwrap defines as we don't have a dynamicly linked library.
use tcpd && epatch "${FILESDIR}/${PN}-${LIBWRAP_PATCH_VER}-libwrap.patch"
@@ -142,10 +127,6 @@ src_unpack() {
# When linking with rpm, you need to link with more libraries.
sed -i -e "s:lrpm:lrpm -lrpmio -lrpmdb:" configure || die "sed failed"
-
- if use kolab ; then
- sed -i -e "s/{LIB_SASL}/{LIB_SASL} -lldap -llber /" configure || die "sed failed"
- fi
}
src_compile() {
@@ -155,32 +136,24 @@ src_compile() {
myconf="${myconf} $(use_with tcpd libwrap)"
myconf="${myconf} $(use_enable kerberos gssapi) $(use_enable kerberos krb5afspts)"
myconf="${myconf} $(use_enable idled)"
- myconf="${myconf} $(use_enable nntp nntp)"
+ myconf="${myconf} $(use_enable nntp)"
myconf="${myconf} $(use_enable replication)"
- if use drac; then
- myconf="${myconf} --with-drac=/usr/$(get_libdir)"
- else
- myconf="${myconf} --without-drac"
- fi
-
if use kerberos; then
- myconf="${myconf} --with-auth=krb5"
+ myconf="${myconf} --with-krb=$(krb5-config --prefix) --with-krbdes=no"
else
- myconf="${myconf} --with-auth=unix"
+ myconf="${myconf} --with-krb=no"
fi
econf \
--enable-murder \
--enable-listext \
--enable-netscapehack \
- --with-extraident=Gentoo \
- --with-service-path=/usr/lib/cyrus \
+ --with-service-path=/usr/$(get_libdir)/cyrus \
--with-cyrus-user=cyrus \
--with-cyrus-group=mail \
--with-com_err=yes \
--without-perl \
- --disable-cyradm \
${myconf} || die "econf failed"
# needed for parallel make. Bug #72352.